Released June 2009 / 2.66, 2.8, or 3.06 GHz Core 2 Duo Processor

275 Questions View all

Trackpad doesn't work after cleaning

Hey there,

i searched already for this topic, but couldn't find my problem.

After i spilled some Water into my MacBook, i took it apart and dryed it.

(i worked with this guide, to see whats going on under the keyboard: MacBook Pro 15" Unibody Mid 2009 Upper Case Replacement)

Unforunately it spilled a little bit over the trackpad. Just to make sure, i took all screws away. And cleaned it as well. Afterwards i realized, that i took out too much screws. I can't find a picture right now, but there is this big silver screw, which i guess is responsible for clicking.

When i reasembled the Trackpad, i couldnt find a right setting for this big silver screw.

The trackpad doesnt do anything, when i touch it. Except in the upper left part, where i can move the mouse a little bit.

Any ideas, how to find out if the Trackpad ist broken or if i just have to adjust the screw... ?

Sincerly,

Simon

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Either some of the water got wicked up between the layers altering the capacitive factor or you damaged the ribbon cable. In any case you'll need to replace the trackpad. It's not repairable.

As to the screw it adjusts the rocking of the button it needs to be set to the point you get a click but don't have any looseness in the button.

Was this answer helpful?

Score 2

Comments:

Thanks for the fast response! After i tried half an hour to find the right setting for the big screw i finally found it. Seems like i was a little bit too impatient with trying ;)

Thanks a lot. This is a great community!

Simon

by

Add a comment

Add your answer

Simon will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 232