Repair and disassembly guides for adapters of all kinds.

17 Questions View all

My hard drive isn't showing up?

I have replaced my old internal hard drive with a new one, it has Mountain Lion already installed and it is ready to go. One problem. I recently purchased the Universal Drive adapter, and when I hook it up to my old hard drive, it powers on and all the lights come on, but my computer doesn't know it is there. Do I need to purchase some kind of enclosure? I have an Imac 2210 (early 2008)

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Try putting your old drive back into your system and then use it to prep your new drive connected to the Universal adapter with Mountain Lion. Then try it again with the new HD installed.

Or

Do you have a second Mac system which you can connect via Ethernet or FireWire putting your system into target mode with your new HD installed. Then prep you new HD with Mountain Lion and connect your old HD to your friends system using the universal adapter to migrate your files over to your new HD.

Was this answer helpful?

Score 2

Comments:

I tried to do it the other way around before I made the switch, however my new drive was not formatted with mountain lion. Do you think that is what it was?

by

Yes you do need to format the drive and install the OS. But, you can also boot from an external HD or CD/DVD that has the OS on it, then prep the drive that way. Which is why I had you putting back the old HD into the system as your boot disk setting is expecting the internal drive having the OS on it. Yes, you can force the system to boot from a different drive using the Option key when you startup your system to get to the boot-up manager. But given your problem I wanted to make sure your disk was OK.

by

Ok.

I now have my old 250 GB hard drive back into my Imac.

I have my new 3 TB hard drive connected to the Universal Drive Adapter, which is plugged into my iMac. Both the SATA and USB lights are on, which tells me that is properly hooked up to the computer. However going to disk utility, it does not appear. I am very confused as to why the disk is not appearing, even after it has been set up with Mountain Lion and formatted. I have no other guesses as to what to do.

by

My objective by the way is to transfer all the data from the old 250 GB drive, to the new 3TB drive using the Universal Driver Adapter, however this isnt possible whenever the drive wont appear when hooked up to the UDA.

by

So you have one of the newer 3TB drives review the drives data sheet and see if you can set the SATA I/O speed down to 1.5Gb/s SATA-I Vs 6.0Bb/s SATA-III speed the drive is designed to run at. Your iMac has a 3.0Gb/s SATA-II interface internally and will likely need to be set at the lower speed. I'm thinking the Universal adapter likewise can't deal with the higher I/O speed and your iMac's USB port is only USB2 not USB3 so it will be on the slow side Vs FireWire if you have access to a FW HD case you could try that.

by

Show 2 more comments

Add a comment

Add your answer

calebbendit will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 612