Why does my PowerBook shut off suddenly & not charge battery?

Powerbook G4 17" Aluminum with old battery suddenly started suddenly shutting down, usually accompanied by getting hot. Replaced power adapter, dc-in, & PRAM battery, and purchased "new" apple battery. With old battery it will boot up and intermittently indicate "charging" (10:00) then "not charging", and continue sudden shut downs. With the new battery, the battery was dead and won't recharge, getting flickering light on the battery but never solid, etc. It will not run just with power supply & no battery. Apple support said logic board wouldn't be the problem, contrary to some related ifixit posts. Will be replacing the battery connector and attempting to recharge the new battery with an external charger. Any other ideas? If the logic board is the problem, can you explain why?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Overheating points to sensor/fan failure, heat sink problems - shutting off is default to save cooking the CPU.

You could have several things going on at once. You are using good problem solving steps to try to identify and eliminate some of the variables. FWIW new batteries have been known to be defective straight out of the box.

Of course you've blown out all the dust, and the fans are spinning up at boot.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1

Comments:

The fans were working, verified by iStat, though I suppose it's possible that they weren't working sufficiently. If both fans were working, would that suggest another issue (other than dead battery)?

by

I was thinking that if the fans weren't working it would cause/contribute to the overheating. . . that they are working and it's still getting hot suggests battery (they get hot when charging or when having "issues") or CUP thermal paste dry/needs refreshing.

by

Update 7.15.13. Got an external battery charger & successfully charged the new battery that previously wouldn't charge in my PB. Replaced the battery connector. (Previously replaced DC-IN card & PRAM battery card with used parts too). PB worked fine w/battery, no sudden shut downs, but would not charge battery after depleted for calibration. Recharged w/ext. charger, reset pwr manager in PB, & tried again. PB works fine, with & w/out pwr adapter. Only anomaly is that battery info monitors and/or charging processes seem inconsistent, sometimes indicating "not charging" when the batt is well under 100%, then changing to indicate charging (lighting bolt); same w/using sys profiler. SEEMs to eventually charge to near 100% (though it can say "charged" when the indic lights on battery are blinking in #5). I'll likely not risk full depletion of batt; PB just couldn't recharge batt fully depleted (though ext ch is nice backup). Comments on progress or anomaly welcomed.

by

Update 7:18.13. After a few days of usage, still noticing oddities in the battery monitoring. For example, with battery at 73% and power adaptor connected, was just showing "(6:56)" to charge with only two applications (Mail & Safari) running, then changed to "(8:59)" while I was typing, then to "not charging". Seem erratic. I had previously used another new power adaptor to eliminate that as a culprit, and can do that again. Pwr Manager was recently reset, so wasn't thinking that's it. Wondering if other issues involved, like firmware, etc? Happy that this old PowerBook is up and running, and seems to be charging, albeit slowly, but still wondering if there is a remaining issue causing the odd battery icon readings???

by

Add a comment

Add your answer

TManer will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 257