Model A1238 / 80, 120, or 160 GB hard drive / black or silver metal front

834 Questions View all

Battery does not charge after changing jack and hold button.

Well, I've been looking through the rest of the answers, but any of them fits with my issue so here it goes...

Last week I changed the hold button and headphone jack (the right side of any headphones I connected just didn't work) with the guide and everything went perfectly. The problem has come two days ago, when I realised the iPod showed the battery icon on the top right corner in red, almost finished. Even though I connect it to charge it, it doesn't. I have tried everything I read on some forums, on the official service and even here, but with no results at all.

I don't know if the battery has simply died or the problem can be related with the reconnected circuits inside. What is your recommendation? Should I buy a new battery and change it? Thanks in advance!

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

santiagoesbert, the first thin g to do is to recheck the connection of the battery cable inside the connector. Make sure it is inserted all the way and straight. The other issues with this model iPod is a poorly designed battery connector. It does have the tendency of breaking of the board. Make sure it is still fully attached. The last thing would be to replace the battery with a new one. Hope this helps, good luck

Was this answer helpful?

Score 2

Comments:

Thanks again. I remember having problems when I reconnected the battery connector, so maybe it is not correctly attached... I'll check that!

by

Done. It was the *#"@+? battery connector hahaha

by

AH, great job:-) Thank you for accepting my answer and best of luck to you.

by

Add a comment

Add your answer

santiagoesbert will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 397