Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

666 Questions View all

it doesn't power on after screwing the logic board.

I replaced the key board and connected all connectors without screwing things, put the lower case and turned on. It worked fine. But after screwing all things, it doesn't power on.

I unscrewed the logic board and put it back, then connected all and tried. It worked fine sometimes but not every time.

I'm doubting that this is caused by the metal plate next to mag safe or below connectors that maybe getting GND. Or small pins on the logic board that may be detecting if the lower case is closed. I'm sure it was closed even not screwed tho.

Any advice?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I suspect that you have placed the screws incorrectly, i.e., you have a long screw in a short screw hole and it is shorting out the board. See if it works without the bottom on.

Was this answer helpful?

Score 1
Add a comment

Add your answer

alexpk will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 72