Problem re-installing new hard-drive

Replaced Hard Drive on my iBook G4, but it is not recognised as a Volume when I try to install my OS 10.3.9 Installation Disc 1. Comes up with Error 36. Have dismantled again and checked all connections. If I go to Disc Utility it is there. Have tried to partition it but both partitions come up with red exclamation marks and it will still not install. Help.

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Hi Dan, Thanks for the information. I think that the supplier should have stated that it was an ATA 133, not ATA 100, in their ad. I will get back to them about this but the postage & packing was more than the Hard Drive! (With Import Tax & Handling) As I got it from the US but live in the UK. I am annoyed, but not with you. Thanks for your help in this matter. Richard

by

Add a comment

2 Answers

Chosen Solution

Make sure you installed an Ultra ATA/100 drive (same as what you had), I've had problems trying to use older drives in these systems.

Look at your older drive you should see a jumper located near the connector block. This is the select between device 0" and "device 1 (Master-Slave as some people call it). Make sure it's correctly set on your new drive.

Was this answer helpful?

Score 2

Comments:

Hi Dan, thanks for your suggestion. Just taken iBook apart again and the Jumper device lable is the same as the old one (the 2 vertical dots to the right, on the lable, are highlighted) and the cable selection dots are the same too. I have installed a Hitachi HTS541660J9AT00 60GB ATA/IDE version to repace the Hitachi HTS541210H9AT00 100GB ATA/IDE version that was broken.

Any other suggestions would be greatly appreciated.

Thanks, Richard

by

Got some bad news for you. The HTS541210H9AT00 is a ATA-133 not ATA-100 so it won't work in this system.

by

If this answered your question please remember to rate (score) and mark it resolved (accepted).

by

Add a comment

Hi Dan,

Sorry for delay in responding.

The boyfriend of a girl I know said he would look at my problem and took my new hard drive in to work.

He found that it was formatted for the Intel Chip and not the Power PC Chip that was in all iBooks.

He has re-formatted it for Power PC and it has installed perfectly!

Apparently the ATA 100 and ATA 130 connections are interchangeable so that was never the problem.

Thought I should let everyone know about this fix for new hard drives for old iBooks.

All new hard drives are probably formatted for the more recent Intel chip.

Thanks for help anyway.

Richard

Was this answer helpful?

Score 0
Add a comment

Add your answer

Richard Jarvis will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 130