I can't format my new HDD (installed in the optical drive)


I recently replaced my failing hard drive with a Samsung 840 SSD (500GB) and wanted to replace the Superdrive with a new 1 TB HGST Travelstar hard drive.

After putting in the SSD and restoring from a time machine backup, everything seemed to work fine.

However, after putting the hard drive in, I couldn't find it under "Devices", probably because it wasn't formatted. I wanted to use Disk Utilities to format it. I tried the method with the "Erase" button as well as the "Partition" method, but every time I tried, a window would pop up telling me: "Unable to write to the last block of the device."

I called the manufacturer of the hard drive and they told me it might be the hard drive itself. So before I'm sending it back, I wanted to know if it might be something else. Can anyone help me? I hope this is the right place, since I'm not sure if it's a hardware problem.. Thank you so much

Edited by: jakob ( )

Add Comment Cancel

Post Answer





Accepted Answer


The HD's SATA spec is SATA III (6Gb/s) but you system is only rated for SATA II (3Gb/s) which is likely the root issue here (More details on the differences). Reviewing the compatibility guide show this drive will not work on your system (this drive has a fixed I/O speed SATA III only) HGST Compatibility Guide. You'll need to get a different vendors drive that can be set to the lower I/O speed.

Add Comment Cancel

Add Your Answer

View Statistics:

Past 24 Hours: 2

Past 7 Days: 8

Past 30 Days: 26

All Time: 842