Model No. A1367 / 8, 16, 32, or 64 GB capacity

1273 Questions View all

Replaced power/volume flex and now the devices power/volume glitching.

Good morning techs, I have a serious problem. I've. Been doing repairs on a iPod 4th generation. It needed a whole new frame assembly so I installed all the "guts" into the new frame and now the power/volume flex is basically unresponsive to the buttons being pressed, BUT will act on there own!! This is not my first swapping of frames but this is becoming my worst nightmare! Help needed ASAP. Customer is getting impatient and I've tried everything I could think of. At this point right now, with NO power/volume flex the devise still will try to power down(THERE'S NO POWER BUTTON SOLDERED ON!!!). Any advise is appreciated.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi Edward,

I would check the following areas:

1. Soldering pads on the motherboard: Are all four contacts of the flex cable correctly soldered onto the motherboard or is there a slack joint?

2. Connection buttons --> flex cable: You might want to check their function. I recommend unsoldering the flex cable from the motherboard. Then take a multimeter, set it to continuity test, and check the different connections/circuits via the soldering pads of the flex cable.

3. Except of the normal connectors, does the motherboard have any other (needless) connections to the new frame?

4. I suppose you already reset the iPod... In case you have not, I would give it a try.

I hope this helps to narrow down the issue.

Steffen

Was this answer helpful?

Score 1
Add a comment

Add your answer

Edward Rousseau will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 76