13" aluminum unibody, 2.0 or 2.4 GHz Core 2 Duo processor.

570 Questions View all

magsafe problem? battery no charge ...

Hello,

I have a macbook A1278 with serial number: SP1AX

When I plug the charger I have no green or red LED and it does not start up.

When I put another battery (charged to 70%) it started very well.

After doing some research I bought 2 MagSafe connectors nine.

ref 820 has the same as 2361A ...

However I tried the other 2 connectors and anything made​​, no changes!

No LED lights ... When started and I plug the charger detects osx charger because I spend mains ... But he wrote: no battery charge ...

If I remove the battery warm, it goes off it is not turned on!

Someone has an idea ...??

Thank you!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Apple MacBook "Core 2 Duo" 2.4 13" (Unibody) Specs

Identifiers: Late 2008 Aluminum - MB467LL/A - MacBook5,1 - A1278 - 2254

by

What does this mean? ref 820 has the same as 2361A and what "other 2 connectors"?

by

Hi,

Sorry I poorly explained ...

I was convinced that this was the MagSafe connector that was involved ... I bought 2.

The reference of the room is apple: 820-2361A ...

But nothing has changed ...

LED lights very slightly green or flashing orange ...

by

Add a comment

2 Answers

Chosen Solution

I suspect your main logic board has a problem in the power section (power transistors have blown). Unlike other models this model has all of the Power circuit on the main logic board Vs the DC in board or Left I/O board.

You'll need to replace the logic board or find someone with the skills and needed parts to fix yours.

Was this answer helpful?

Score 1
Add a comment

My Mac had no power going to it.So got new adapter still no power even new battery as mine my Macbook is a late 2008 model still no power.In the end i got a new DC board and every thing come back working as it should. So it could maybe just be the same for you

Was this answer helpful?

Score 0

Comments:

Hal - It's likely your model has the power transistors on the DC in board or Left I/O board. Which explains why your action worked. Sorry to say Apple changes things up enough between the models that you need to be careful on how you diagnose which part to replace, more so in the power side of things.

by

Yep fully understand that my Macbook is a A1278 So was just giving some info on what fixed mine.Opened up few MacBooks and seen how different the insides are.

by

Add a comment

Add your answer

Eldoctor62 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 3

All Time: 805