The Samsung Galaxy Ace II X features a 1 GHz processor, a 5MP camera, and a 800x480 TFT screen.

17 Questions View all

After swapping digitizer, device won't boot

Hi all, I recently swapped out the digitizer on a S7560M, and since then, the device is stuck in a boot loop, powers up, goes to logo, reboots.

I have torn down and re-assembled the device to check connections, all appears ok.

Can't get to safe mode or recovery, I'm stuck.

Since this is a fairly new device I can't find any further info. I have repaired many different devices over the years, and have not had an issue like this.

any pointers will be greatly appreciated.

Answered! View the answer I have this problem too

Is this a good question?

Score 3
Add a comment

19 Answers

Chosen Solution

I own a cell repair store. We had the same issues with these phones. We figured out what the problem is. All the parts suppliers list the S7560m and the S7562 as the same part. They are not. I am not sure if the '60 parts work in the '62, but I know for a fact the '62 doesn't work in the '60.

There is almost no visual difference between the two parts, which makes it hard for everyone to tell the difference. There is a couple minor differences, like the area around the home button on the inside (hard to explain).

Once you ensure you have the right part, it will work. Trust me. The hard part is convincing the suppliers that they are in fact different and to ship the correct one.

Hope that helps

Mark

Was this answer helpful?

Score 4

Comments:

Thats the reason in 99.999% case!

by

Add a comment

Hi All,

I also had this same issue after replacing the Digitiser from an ebay replacement.

I am very pleased however to have resolved :-)

Initially i checked all contacts of ribbons I had removed as part of the process but all appeared to be ok.

The answer to resolving this was the ribbon cable attached to the new digitiser. There are white dashes on the board it self so when fitting the ribbon cable from the digitiser back into its housing ensure that you line up the white line on the ribbon exactly the the dashes on the board itself. Mine was off alignment and I was just getting the boot up the black screen saving Samsung Galaxy Ace 2.

I have since tested again by mis-alligning and i get the stuck at boot again.

When I then lined up again. HEY PRESTO. Please try it definately works

Thanks all.

Was this answer helpful?

Score 1
Add a comment

The screen that says DUOS is for the s7562 and won't work/will work poorly on the s7560. The inverse is also true, this is due to the resolution of the LCD on both models being different. Suppliers still haven't rectified the issue to this day and insist the 7562 digi will work in the 7560. It does not.

Was this answer helpful?

Score 1

Comments:

Ok so I have a galaxy alpha G850a that I replaced the screen/ digitizer on and is now fully loading to the point where I can here the notifications and such how ever the screen won't leave the Samsung galaxy alpha screen. I have tried loading the recovery boot menu and it won't completely load shows the blue recovery boot in the top left corner but won't go past that and it will load into download mode and actually show that screen any help or info at all would be appreciated thanks l.

by

it's most likely the wrong version of the screen and the phone can't load the driver. Verify the screen you purchased is your model as they can vary based on country and proofreading

provider. That's what had me messed up on the original post with the Ace.

by

Add a comment

Hi there, I am having the exact same problem! I replaced my Samsung galaxy ace 2 digitizer not even 2 days ago. I had thought it went fine until I tried to power it up and the screen was just black with the model number. Plugged it into the wall to charge for a few hours, it has still just had the charging symbol on empty and not even moving. I took it apart a few times again, re-checked connections and they all appeared fine but still no power up.

This is very frustrating, I'm not sure what to do next. Considering trying a factory reset but I don't know how to do it yet, still googling to get more information. I had replaced the part myself to try and save money but now it's looking like I'll have to get someone else to take a look at it.

Have you had any success with yours??

Was this answer helpful?

Score 0

Comments:

No love yet M8, I'm leaning toward it being an issue with the new digitizer, I'm going to swap the old digi back in, and see what that does, and I'll post my results

by

IT Worked!

I tore device down to bare lcd, re-installed original digitizer,

VOILA! powered up and loaded straight to lock screen! all appears to be working normally, except crack in digi which was what started this in the frst place. Oh well looks like the client is getting her phone back cracked, cause i'm not about to replace this digitizer again.

Xpider

by

Add a comment

yeah this is my exact problem. new digi wont boot past samsung screen , swapped back in old cracked one, works, took out digi entirely and samsung screen no booting up. it doesn't reconize new digitizer apparently. faulty or incompatible. any help would be appreciated

UPDATE:

I need to investigate further, but check your fcc id . i beleive that samsung is now , probably for cheaper production costs, marketing phone model gt-s7560m constructed mainly of guts from a newer phone. s7562. i will post anymore info when i get it. going to get digitizer for s7562 and install.

Was this answer helpful?

Score 0
Add a comment

I have this exact issue. I have torn things apart for years, so I have a good feel for when things go right, and I took my time taking the phone apart,but it won't boot. No recovery, nothing.

My old screen is smashed, and I need this fixed. I am assuming you just bought a new phone instead.

If you made any headway please let me know, I am fixing my son's phone, and he has been devastated since dropping his phone.

Any help is greatly appreciated

Was this answer helpful?

Score 0

Comments:

Hi Gary,

I actually gave the device back to my client with the original cracked Digitizer installed. I explained to her the replacement digitizers don't always work properly based on my research. I didn't want to have to purchase 2 0r 3 digitizers to find one that worked. I have had 2 more of these phones since then in for repair, and the replacement digi's haven't worked on any of them. I have tried a complete wipe and restore on all three prior to replacing the screens, and all had the same effect, no boot with the new digitizer installed.

I have since been telling clients either to not purchase this device, or not bring it to me if it cracks, as they are aparrently unrepairable.

Xpider

by

Add a comment

I've used both - neither seem to work. Don't quite know what to do now!

Was this answer helpful?

Score 0
Add a comment

hey all

I just order this part and put into cell phone and its doing the same thing and I did check all cables and everything is hooked up right.... any ideas?

Was this answer helpful?

Score 0
Add a comment

Same as above replaced the digitizer . did notice the new one had slightly longer end to the ribbon cable so impossible to line up with the current line . extremely frustrating had it apart few times checking the aliment . and having no joy and have noticed few other deference but unable to install the old one as it is proper fubar . how can i find out what part i need please any detail be good thanks !

Was this answer helpful?

Score 0
Add a comment

Same symptom. All seemed to go well with the digitizer replacement but no response to power-on switch. But when opened up again found that somehow when reassembling I managed to tear the power on/off ribbon cable!

It boots by inserting a usb (charger, sync) cable into the phone while simultaneously holding down the Home and Volume Up buttons. So I just put shortcuts to the Widgets: Screen Off, Airplane Mode, GPS Toggle, Bluetooth Toggle (energy savers) on the Home screen and keep the phone on the whole time. ['Just have to remember not to remove the battery without having a (phone-)USB plug nearby.]

I got the replacement switch on eBay but not sure my (de)soldering skills are up to this delicate task. (More damage?!)

Was this answer helpful?

Score 0
Add a comment

OK i have had same issue as all other . and seems like matey frome earlier post is correct . some supplies are selling the gt version and the plane i380 as working on both well it bloody don't !! I sourced one specific for the gt and it work straight of . and still the supplier insists 100% it defiantly works with both. so sorry to say you will have to buy the correct one i did find mine on ebay for a 10 pound. also you can see physical deferences

1. ribbon is too long and no way to make the lines line up.

2. down near the home button the vertical lines are longer on the gt version ( on back )

3. on the back top there is gnd and x9 symbols below the earpieace hole on left as you looking at it from back on plain version i.e not gt . there few more deferences but they main ones . i hope this helps . good luck !!

Was this answer helpful?

Score 0
Add a comment

On the yellow ribbon that runs through the frame to the board there are two things to look for.

1. The red end of the ribbon is supposed to line up with the white line, no line up not the right part.

2. That same cable says the part number on it. The one I have in front of me that's not working for this phone says MDH-7562-r54w

Was this answer helpful?

Score 0
Add a comment

I had the same problem. I eventually resolved it by pushing the ribbon cable in deeper into the mount. The white line on the cable ends up almost even with the front of the mount. When I lined up the lines it didn't work.

The was for a S7560m as well.

Was this answer helpful?

Score 0
Add a comment

I had this problem too. Mark Chaplin's post worked for me. The circuitry on the ribbon cable of the incorrect digitizer was slightly different so that might be a way of telling them apart.

Was this answer helpful?

Score 0
Add a comment

I ve got the answer finaly !!! the digitizer S7562 dont match and this problem on S7560m... Trust me, make sure the digitizer is right !!!!!! tell the f"" fournisher!!!! SOLVE!!!!!

Was this answer helpful?

Score 0

Comments:

that the cause! Thank's...

by

Add a comment

hi i have found to have this i have a solution i grounded the battery to the connector and then once done plug it in at the mains the phone will then turn on dont touch intill it has been on charge for at least 10-15 mins

Was this answer helpful?

Score 0
Add a comment

I have the same issue with a different Samsung device it's a galaxy grand prime and I have seen the same problem with a galaxy trend plus the problem is that the digitizer is not original and sometimes the device will not boot. to fix it change the digitizer for a different one

Was this answer helpful?

Score 0
Add a comment

Xpider, Thank you for asking this question. Mark Chaplin, and everyone else who mentioned the digitizer as not being entirely compatible, thank you, too.

My niece dropped her phone that was not this exact model. The LCD got messed up but the glass didn't crack. I bought a kit off of eBay and it wouldn't work. The screen would display the Samsung splash screen and then go into a grey striped mess. I took the phone apart a dozen or more times and double checked the connections. (I cracked the new glass in the process by not being careful.) I even tried to restore the phone's OS. Nothing worked.

Because of this question, and especially the answers, I took the new glass screen off, which I had cracked during my repeated teardowns. I put the old original grey glass (digitizer) back onto the phone and mostly put it back together. It works just fine. I didn't replace all of the screws because now I have to take it apart again to clean the inside of the digitizer and the LCD. I didn't clean them all up because I wasn't sure this was going to work any way.

When the repair doesn't work double check the model of the digitizer. - Greg

Was this answer helpful?

Score 0
Add a comment

How can I tell if I have the wrong part? I am having the same problem with my Samsung Galaxy Light SGH-T399 phone. I ordered replacement digitizer from Amazon and installed it with no problems, but just getting to Logo screen and freezes. The phone WAS working properly with the cracked screen, but unfortunately, I tore the ribbon when removing it from the phone so I cannot check to see if it would still work (but I suspect it would). Is the number printed under the ribbon a model number? because they are different. Thanks for your time.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Xpider will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 32

Past 30 Days: 86

All Time: 11,540