Model No. A1367 / 8, 16, 32, or 64 GB capacity

1269 Questions View all

power button not working

hi. the power button was not working but it still "clicked". volume buttons worked fine.

i replaced the flex cable. but still the same.

i either got a naff flex cable or the is a prob with logic board. any idears would be helpfull

thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi Will,

Since you replaced the flex cable already, it seems to be ok.

However, I would check on both ends of the flex cable. First, check the soldering pad of the power button on the logic board. Is it ok?

Second, and what seems to be the actual problem, check the power button itself. Sometimes the metal plate inside of it can change its position over the time. Or dust can be in between the button and the contact area of the flex cable (which might not be the case since it's a new flex cable and you might have already cleaned that area). You said it still clicks, but I would check anyways. But before you do that, here is what I would do:

If you have a multimeter, unsolder the flex cable on the logic board and check the circuit of the power button in its 'built in' condition. Do you get a beep of the multimeter when you push the button?

Steffen

Was this answer helpful?

Score 1

Comments:

hmm yes i need to check flex cable for continuity like you said

just to eliminate the cable from the equation. at least that will tell me if its a naff cable. i have a feeling that the cable will be ok but i will let you know. have you ever heard of this fault to be a logic board problem?. thanks for your help

by

Hi Will,

If you speak of the logic board issue as being to be connected to a software issue, I have to admit that I am more into hardware than software. So, I always look at the "touchable" parts first and check them out "manually". Software has never been my hobbyhorse.

But to answer your question: No, unfortunately, I have never heard of this fault to be related to a problem of or on the logic board. Sorry.

Steffen

by

Add a comment

Add your answer

will buck will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 408