The Kenmore Elite HE3 is a washing machine by Kenmore.

482 Questions View all

Continuing error codes Sud and F21 after trouble shooting

Bought great working washer from a friend. On first cycle after move it showed error code Sud and then F21. Tried running normal cylcle without detergent. Then tried Rinse and Spin several times. Cleaned out drain. Nothing in it except water carefully collected in shallow pan placed under washer. No hose kinks. No loose wires. Unplugged it for reset with no positive results. Replaced pressure switch. Replaced pump motor. What's next? Throw it out?

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

I'm at a complete loss I don't know what to do I've spent over $300 trying to fix the machine for $200 more I could have just bought a new one it makes me really sad because it's really not that old Sears used to be one of the best places to buy Electronics washers dryers fridge stove now they seem to be garbage throwaways after couple of years and makes you really sad because I work so hard for my money and I just don't have it to throw away every couple of years but it doesn't seem to matter who makes it anymore all manufactured by the same place and I slap different labels on them so really you're just buying the same garbage from store to store throwaways

by

Add a comment

5 Answers

Chosen Solution

From Adam Hintz

The F21 error on this line of washers is the machines way of saying the water took to long to drain from the tub. This could be a problem with one of the washer parts including the drain pump itself, how the drain hose enters the stand pipe, or maybe even something is stuck somewhere in the drain system and is preventing the water from flowing properly. Not quite an emergency, but it is an indication of a problem and a problem that can lead to something bigger if not looked into.

From Old Turkey on SUD - According to the service manual there are a few possibilities

Sud - SUDS LOCK (Overdose of Detergent detected during the Wash Cycle)

The motor control unit senses a suds lock condition by analyzing the current draw on the drive motor. If “Sud” is displayed a potential suds lock is detected. This may signify a bad pump, an extra heavy load, excessive detergent, or excessive suds.

• If too much detergent was used, run the unit through a Rinse/ Spin cycle then a Normal cycle without adding any detergent. This should clear the unit of the excess detergent.

• Check the drain hose and make sure it is not plugged or kinked

• Check Wire Harness connections to the Drain Pump, Pressure Switch, and Central Control Unit (CCU)

• Check/ Clean Drain Pump Filter of foreign objects

• Check Drain Pump

• Check the Pressure Switch

• Check CCU

To make your job easier, try to download the manual from here. Good luck and I hope it helps.

Was this answer helpful?

Score 3

Comments:

On some front load units there is also a chamber located on the back of the washer where the pressure switch hose connects to the back of the tub. This chamber can become clogged with sediment, and also accumulate particulates from using non " high efficiancy" soap over long periods of time. Clearing out this chamber can often correct the problem. This chamber effects the pressure value on the pressure switch itself. It is held to the back of the rear tub assembly by one small screw.

by

Add a comment

My son just had the f21 error code and once in a while the sud code too. Water would remain in the tub.

Cleaned out the filter underneath. Worked once then repeated the error. Took pump apart and impeller resistance against magnets was felt and could hear pump running.

Ended up with repairman coming out and found out it was an obstruction in the ball valve drain. Google didn't pop up with any f21 errors that showed the ball valve being a problem. I didn't see him take it apart but it doesn't look hard from the diagram. Just another hose clamp beyond taking the pump out.

See the diagram here part#6

F02 Error Code HE3 Elite Washer

There was a piece of this material (several times thicker than a dryer sheet) about 4x8 plugging it up. No idea where it came from.

Was this answer helpful?

Score 3
Add a comment

I had this same problem, and it turned out to be the impeller inside of the pump. It was almost half broken off when I took apart the pump. Not thrilled about having to buy a new pump, but better than paying for a repairman to come out.

Was this answer helpful?

Score 1
Add a comment

I had the same problem - still getting F21 & SUD codes even after changing the pressure switch and the drain pump. No hose kinks or anything wrong with the drain lines. I finally took the drain lines all off - from the drain pump up to the plastic elbow near the top where it exited the washer, as well as the next line from that same elbow to where it drains into the house drain. We took them outside and ran water through them with a garden hose nozzle. There was some build up of gunk in those lines. I thought it was hardly enough to make much difference, but apparently it was, because after cleaning and reinstalling the lines, my wife has run 6 loads through the washer without the codes coming up again, so I'm hoping that it is finally fixed. Bottom line, apparently there was just enough restriction in the lines to slow the draining process enough to throw the codes. Hope this helps!

Was this answer helpful?

Score 0

Comments:

Just an update. As of today, April 11, 2017, our washer still hasn't thrown anymore codes and is still running fine.

by

Add a comment

We just dealt with this today. Cleaned out the trap (which was absolutely clogged) and happily put the washer back together, only to get the same friggin code the next use. We took the front apart again, and water came pouring out, so it wasn't anything there. We just took the drain line off the back of the unit and found standing water in the line. There was no water going through the line so there was a clog somewhere in. We eventually got the line cleared and water flowing through at a good rate. We're crossing our fingers that this is it, because if it isn't I'm about to go out of my mind. So far so good no, annoying beep. SUCCESS!!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Wendy Lynch will be eternally grateful.
View Statistics:

Past 24 Hours: 43

Past 7 Days: 326

Past 30 Days: 1,459

All Time: 37,328