no display even after changing item Q9400

Block Image

Hi,

A few weeks ago, my Macbook pro(A1212) stopped displaying. It only showed a white screen, but you could get the display via an external monitor. A friend looked at it and we discovered a burnt Mosfet (SI3443DV) which was item Q9400 on the motherboard. He went and changed it but it only displayed for less than 5 minutes and it went back to the white screen. would you please advice on what to do since i am not in a financial position to take it for repairs at the apple store?

P.s The component is pointed out on the image above.

Joe

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Could you post a picture of the board and point out the component that you replaced. This would help us figure out the problem allot better.

by

Hi john, i uploaded an image with a pointer to the component on the original question. Thanks for your help.

joe

by

Add a comment

1 Answer

Chosen Solution

It sounds to me like the new one has burnt out as well. Was it orientated the correct way? I know that Mosfets are used as power protection and load switches. It is very possible that burned out because it is acting as power management and builds up allot of heat. I think it would be interesting to open the computer back up and take a look.

Hope this helps,

John H. Laney

Was this answer helpful?

Score 0
Add a comment

Add your answer

Joe will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 145