Revamped version of the iPhone 3G with faster processing speeds. Repair of this device is similar to the 3G, and requires simple screwdrivers and prying tools. Model A1303 / 16 or 32 GB capacity / black or white plastic back.

1950 Questions View all

No Service when 3G is enabled.

Dear iFixit,

I am having a problem for a bit with my old 3GS: I get very poor connection when 3G is enabled. Basically, I have some network for a few minutes (10-15, it varies) then switches to "searching" and then "No Network". I usually don't get any network back.

It is interesting to note that when 3G is off, I have absolutely no problem getting a stable GPRS/EDGE connection.

I am currently running iOS v6.1, but I have this problem for ages.

Therefore my question is: Is there a different antenna for 3G and EDGE/GRPS? Would you recommend changing it?

Regards,

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Most Helpful Answer

Hello,first off all sorry for bad eng. but ill try to help you

So i saw a lot users od iphone have problem with iphone 3g/gs. No service on 3g network or when its off,i have that phone also and i have solution that worked 100%

problem is on signas switcher that is located on this picture you can see them: lower part of iphone.

http://i87.servimg.com/u/f87/13/27/39/62...

So here it is,take a hair dryer,a turn it on,heat this chips for about 10 sec,then whit your fingers push chips on logicboard,get iphone back on,go to settings-reset then reset network settings,and its workig :)

if its now working try to heat and push chips again

please share this solution becouse i cant see any other solution for this problem

and please correct my words if there is something wrong

Block Image

Was this answer helpful?

Score 2

Comments:

jurica, nice answer, but can you describe the location of the "signas switcher" a bit better?

by

I do it by the way,but it does not work.

I must push chips on logicboard more powerfully?

by

Add a comment

Hi,

i had the same problem with an old 3GS. It was an error in the logic board, without a chance to fix it.

Was this answer helpful?

Score 0
Add a comment

can this problem be solved in same manner for android phones?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Ace Spizzer will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 17

All Time: 7,767