Released June 2009 / 2.53 GHz Core 2 Duo Processor

139 Questions View all

Can't get past folder with questions mark

System crashed, assumed hard drive, could not repair with diskutil, replaced with new drive. When attempting to partition got Posix errors, replaced with known good drive. Did the command, option, R, P, Power and still get a Folder with ?. ~Assume~ potential bad sata cable for hdd, black cable, shows what appears to be a crack.

Pulled out superdrive, installed New SSD with OS there, could not get past the boot point of WPA2 pass phrase, spinning mouse of death. So I've gotten further, but. . .Not very far into the new startup process.

I assumed it could be the cable for the harddrive, so I moved over to the optical slot, and used that cable(stubby, short one.) Which allowed me to get ~further. But . . . I also unplugged the cable for the hdd at the Motherboard, out of fear that it was causing signals to cross.

Is it worth it for me to purchase a hard drive internal sata cable ? Or is it time to head into the Genius bar?

thanks

rick

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I had two of these 13" 2009 machines in this week, a 2.26 GHz and a 2.53. Both had defective hard drive cables. I even had problems with an optical bay hard drive adapter with the drives in place. If it will boot from the DVD with the installation disk and the hard drive disconnected, replacing the cable with a new one solved the issue on both machines. Note, two ordered used cables also failed, only the new ones worked.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Rick Lowe will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 177