Fourth generation iPhone. Repair is straightforward, but the front glass and LCD must be replaced as a unit. GSM / 8, 16, or 32 GB capacity / Model A1332 / Black and White.

3238 Questions View all
Question Closed

iPhone 4 After Repair Stuck on Apple Logo & Cannot Restore

Well this is not my first repair. I repair many of my own, parent's and siblings iphones. This particular iphone 4 has been in service since the iphone 4 first came out and have been running well. Of course there have been wear downs so I replaced the aux flex cable, power button and repaired the home button in the past.

So I have a lot of experience and made sure nothing wrong happened until earlier today.

The iphone was running flawless, I fixed everything except for this weird issue where the top mic wouldnt work during calls on speaker mode. It worked; however, when testing voice memo. I read online to fix this was to simply clean out the top mic hole, so i disassebled it and cleaned it and put it back together... except now its stuck on the apple logo. I thought it was fine as I could restore it. Weirdly enough I couldnt put it in DFU mode, so I put it in recovery mode to restore. It was identified in itunes but along extracting when the iphone was supposed to restart it just dies for a second and resumes frozen on the apple logo. Also strangely enough, it CANNOT run without the battery, so the only way to keep it running would have it stay plugged in. If I unplugged it it would die instantly.

So my question, is it because the battery is bad now? Does the iphone 4 not restore because it must restart for a split second, so if you had a bad battery it would cut the power during this second and not restore? Please someone help me out here.

Best Regards,


Update 1

Well I managed to fix the errors but now I have itunes error 3194. The error is related to downgrading and jailbreaking but my iphone is not jailbroken and im updating to the latest NON CUSTOM firmware.

Can anyone provide any sort of input?

Update 2

I just sold the iphone 4 on craigslist. Luckily sold it for $120 for the phone only. It was the motherboard that went bad and checked on ebay. Motherboards go for $90-100+ so I was able to recover what I lost.

Oh well.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

3 Answers

Most Helpful Answer

You have to delete or put # in front of the ip for saurik server from your hosts file

If you look online "saurik server" follow the guide to get to the hosts file and then you can edit the ip either delete it or put the # in front of it.

Was this answer helpful?

Score 1


Ive already done that. So now I dont get the invalid build but now I get error 2001 again.

I stopped jailbreaking my phone ever since I got it unlocked about a month ago and has worked flawlessly. I checked everywhere how to fix 2001 and I still get the error :/


Add a comment

take off the battery for 24 hours and back it will wording again

Was this answer helpful?

Score 0


Just received my new battery today from ebay. I replaced the battery with the new one and still same symptoms.


It gets error 2001, 1601 and sometimes 21 so i fix it by putting it in pwned DFU mode, but now it gets the error "The iPhone 'iPhone' could not be restored. This device isnt eligible for the requested build."



Add a comment

just change the battery

Was this answer helpful?

Score 0
Add a comment
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 4

All Time: 3,330