iMac G4 17" 800MHz Widescreen. Now boots black screen. 3 beeps.

My Beloved I-mac I have had since new has gone wrong. In the past I have revived it. Replacing, Inverter, Hard Drive, Superdrive.

It seems to boot going bong. fans start and has no sleep light or LCD action. Keyboard does not seem to respond. Mouse light on bottom seems to light when USB stuck in machine.

I tried the resetting the PRAM holding the power button and plugging it into the mains type action. Did not seem to work.

I took the bottom off and took out the user slot accessible slot RAM and the airport card restarted it. It does the same not booting properly and bleeping 3 times.

Took the machine apart. Reseating the internal RAM. Checked the PRAM battery voltage, which was 3.61v.

Is it the internal RAM gone bad, or the power supply or the hard drive going down again.

Any help would be helpful dudes. Many thanks in advance.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

Chosen Solution

There are two RAM slots on the 800 MHz machine. Maximum RAM is 1 GB. Try one of your sticks in each slot, one at a time to test both the RAM and the slot. Your RAM may have failed or a slot may have failed. Here's the guide I wrote for replacing the battery but it will also get you into the machine to change the RAM: iMac G4 17 800 MHz EMC 1936 Battery Replacement

Was this answer helpful?

Score 2

Comments:

Thanks for your reply. I did write that I reseated the internal RAM. I have the maximum capacity in both slots (1GB). Do you know if it will boot will just the user accessible slot filled and the factory one empty? as they are not interchangeable.

I was just surprized at the lack of activity if it is just the internal RAM gone!

I'm waiting for new RAM to arrive. I will keep you up to date with the progress. Thanks for now :)

by

Please do the procedure I talked about so you know if you have a bad slot or bad RAM.

by

When I took the Internal factory RAM out did not want too start. Nothing completely dead. Took the user accessible RAM out and gives the 3 bleeps. I take it must be the internal factory RAM died. What do you think?

by

I think you don't follow directions very well. Please do the procedure I talked about so you know if you have a bad slot or bad RAM.

by

Thanks for the down vote Jason. Good luck on solving your problem.

by

Add a comment
Most Helpful Answer

Hi, According to Apple the three beeps mean your ram is no good. (Link included) I know you can hear a chime but see if you can find another stick of ram to try. Good luck.

http://support.apple.com/kb/TA43884

Was this answer helpful?

Score 3

Comments:

Thanks for you reply, I did deduce that looking around and reading through the lines of what I posted. But thanks anyway.

by

I replaced the RAM in the factory slot. When it eventually arrived (Kingston KVR133X64C3512 (512 MB, SDRAM, 133 MHz, DIMM 168-pin). The first few times I booted it chimed. Screen came on with the apple. Not quite to the spinning roundal. Just died.

Did this half a dozen times. Used the hairdryer trick on the power supply from the top.

link to hairdryer video on youtube.com

Once it was warmed seemed to work fine. So it was a combo of power supply dying/be cold plus the Factory RAM going bad. Thanks to everyone that Helped.

Big up Mayer + rj713!

by

Add a comment

Add your answer

Jason G will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 19

All Time: 1,301