Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

702 Questions View all

MBP A1278 Error 4SNS/1/c0000008: TsOP--124

I have a MBP 2011 13 A1278 cannot find the left palm rest sensor????

err 4SNS/1/c0000008: TsOP--124


Answered! View the answer I have this problem too

Is this a good question?

Score 0


Please tell us the last 4 charaters of your serial number, so we can determine your exact machine. Also, please tell us more about your problem, what your MacBook is doing or not doing.


Add a comment
New Battery = Faster iPhone
Fix Kits starting at $16.99

2 Answers

Chosen Solution

Ts0P = Trackpad flex cable

I think you have to look a bit deeper here. I suspect something was spilled into the keyboard/trackpad causing it to error out here. If you're sure the sensor is gone you'll need to replace the trackpad flex cable.

I would also install a good temperature monitor app like: Temperature Gauge Pro to better monitor the sensors.

Was this answer helpful?

Score 2


I had the same problem and I got a replacement ribbon flex cable (connecting the trackpad to the logic board). The problem is solved. Thanks a lot.


Add a comment

I have the same error code;


Fan runs at max speed all the time,

In normal boot, kernel_task is taking over 100% CPU

In safe boot , problem is gone.

If ioplatformplugins kext/ahci SMC profile for MBP 8,1 is removed (the model of my crapbook) the computer runs normal, but the fans are at max speed.

I need location of sensor (palm sensor) which I believe is under trackpad, because I refuse to pay crApple $600 to herp the derp.

Thanks guys!!

Was this answer helpful?

Score 0


Your systems specs: MacBookPro8,3 - MacBook Pro 17" (Late 2011)


You'll need to follow this guide: MacBook Pro 15" Unibody Late 2011 Trackpad Replacement as we don't have one explicitly for the 17" model.


Add a comment

Add your answer

jwills1 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 19

All Time: 2,430