Started shifting hard, and stuck in 1st. Now won't start?

I have a 1995 Chevy Tahoe, 4WD/350 (non-Vortec). After washing it, the transmission started shifting hard, and then stuck in 1st or 2nd; when killed it wouldnt start unless i poured a little gas in the throttle body, and it will start and run till i kill it. i have changed the fuel filter

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Eric,

There is not a lot of information on the GM Service Information website for your vehicle due to its age. There is a service bulletin #67-71-53B - No Upshift/2nd Gear Only After Cold Start-Intermittent DTC 87-High Ratio Error. The fix for this is to replace the PCM EPROM.

I would suggest that you take this to a trained technician for further diagnosis. You have a couple problems. First you have a no start problem. There could be many things wrong to cause this; from a bad fuel pump to a faulty PCM, to a MAF sensor problem, to a fuel pressure regulator problem, to a TPS problem or even a CKP sensor problem. Any of these problems will cause a no start. Try pushing the accelerator to the floor to start the vehicle. By doing this you cause the PCM to ignore certain inputs and attempt a start.

Secondly you have a drive line problem. It could be anything; from a restricted transmission filter, to a TCC solenoid stuck on, a locked torque converter clutch, a faulty transmission valve body, a transfer case that is stuck in 4X4 low, a transfer case that is locked up, ect.

There might be a wire that is corroded somewhere that could cause issues. Or you may need a new PROM in the PCM. These are all common problems that GM's around yout year have had.

Good luck,

- B.

Was this answer helpful?

Score 1
Add a comment

Add your answer

eric lee will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 409