Can't Restore iPhone 4 After Water Damage

Hi everyone.

I dropped my iPhone 4 into water for a few sec. I've put it off almost immediately, but then i could not get it on again. So i tried to restore my phone using itunes, ireb, redsn0w and everything else.. but no luck: when it is not in dfu my iphone just reboot after apple logo (but without booting iOS); when i try to recover it in iTunes i just keep getting a "1601" - "2001" error, before it start the installation process.

I asked a friend of mine his iphone to try what damage could be.. so after some tryes i've put my dock connector on his phone, and i saw that his phone was not booting, just like mine did. On mine i also replaced the battery from his phone, without luck (it didn't change anything).

So i bought a dock connector and i replaced it. Nothing yet.

Last thing i've done is cleaning my iPhone motherboard with isopropyl alcohol 99% pure.. but, again, no luck.

What do you suggest me to do to revive my phone? Thanks a lot.

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Any help? :/

by RyuBlade94

So just to recap, you replaced the battery, the dock connector and you cleaned the board properly with isopropyl alcohol? Do you have a multimeter and can check small components? Both of the errors listed are general USB errors....

by oldturkey03

Have you tried this yet for the 1601 error: Windows: Close iTunes Start –> Programs –> Accessories Run Notepad or WordPad (as administrator on windows 7) Click “Open..” from File menu. Browse to Windows/System32/drivers/etc In "files of type:" select all documents Open "hosts" Either delete all line that has "gs.apple.com", or add a "#" sign at the beginning of the line to comment it out Hit Save Reboot computer for changes to take effect.

by oldturkey03

I have not a multimeter :/ Anyway i checked on the hosts file already, but there are no apple addesses listed there. I also tryed to restore on a different computer (3, actually: my old macbook, my iMac and a Vaio notebook).. but nothing changes. I really don't know what to do :/

by RyuBlade94

there are some USB fuses you could check, but for that you need a multimeter/ohmmeter

by oldturkey03

Add a comment