Why can't I download or find older versions of itunes?

I have a graphite iMac G3 running 10.4.11 like my G4, I downloaded itunes 9.2.1 on it (the G4) and it worked fine, I did on the G3 and it said i needed a G4, G5. or intel processor. I tried downloading 8 or 7 and I cant find any links,

please help

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Ted Mayer, I get my old versions from here. Hope this helps, good luck

Was this answer helpful?

Score 0

Comments:

I need the mac version, I went to the mac page and searched itunes and i came up, but there were no links

by

Nevermind, it worked =D

by

Great that you got it going :-)

by

Add a comment

Add your answer

Ted Mayer will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 512