dead, no sound of activity.

dead, no sound of activity.

Fuse in power cable is 10 amp ? is this correct for machine.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Here's the 96 page User's Manual for downloading: http://www.pdfoo.com/mobilephones/251-83...

These machines have been plagued with bad capacitors. Inspect the 25 caps on the board for corrosion and/or bulging. The power supplies area also frequent problems, look for a burned spot right where the cables go in.

iFixit has lots of threads on the problems of this machine. In the search box at the upper left hand corner just type in "bulging" to find many of them.

Here's a very technical thread to some of the problems: http://www.badcaps.net/forum/showthread....

Was this answer helpful?

Score 2

Comments:

Thanks for your reply. The unit is a iMac G5 17" Model A 1058. I checked the capacitors and they looked OK. The two green lights on the board functioned OK. The Hard Drive eventually kicked in but was sounding extremely quiet, there was no power to the cooling fans. Some power was getting through to the HD but not to the rest of unit. Could bad HD affect function of boot sequence ?

Wernyhora

by

Add a comment

Check my answer in this question:

iMac G5 20" 1.8GHz no display

Was this answer helpful?

Score 1
Add a comment

Add your answer

Wernyhora will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,416