iMac Intel 27". EMC 2309 (Late 2009, Core 2 Duo 3.06 or 3.33 GHz), EMC 2374 (Late 2009, Core i5 2.66 GHz or Core i7 2.8 GHz)

338 Questions View all

iMac screen stay black (logicboard issue?)

Hello,

After having unplugged the iMac, it won't boot and the screen remains black (no start-up sound). The computer was in suspended mode when I disconnect the electric wire.

As I replace the HardDriver (for an SSD which was amazing... till now lol) apple waranty dont works (i've already tried :p).

After some researches i was told that it could be the logicboard and more specificly the bios battery. I replace it (not so easy :s) and now I can hear the start-up sound again... but still the screen remains black :-(

As the logicboard replacement cost 1500$ i don't know what to do... should i throw my all new iMac to the trash ? mdr

Thanks for any response / lead :p

Answered! View the answer I have this problem too

Is this a good question?

Score 2

Comments:

I'm willing to hear anything and maybe I wrong... maybe that's not the logicboard, I'm not really sure (while almost though) and any comment would be great !

Thanks

by

Check if the screen show the image even when the light is off. If yes is the problem is in the backlight and in that case you have to change the LED board, which you can buy for something between 50 and 150 dollars. Good luck

by

Add a comment

3 Answers

Chosen Solution

Check the diagnostic lights on the motherboard.

LED 1 indicates that trickle voltage from the power supply has been detected. This LED will be ON when the computer is turned off and your power supply is working correctly.

LED 2 indicates that the main logic board has detected proper power from the power supply when the computer is turned on. This LED will be ON when the computer is turned on and the power supply is working correctly.

LED 3 indicates that the computer and the LCD display are communicating. This LED will be ON when the computer is turned on and video signal is being generated.

LED 4 lights only if the computer detects an over-temperature condition. This LED will be OFF when the computer is turned on and running at the correct temperature.

Was this answer helpful?

Score 3

Comments:

#3 LED on thru me. Trying hooking up to an external monitor to check the graphics chip (GPU) to try to isolate the problem.

by

+ Ralph

by

Same issue here except that LED #2 is flashing slowly (off for 4-5 seconds, on for 2 seconds, repeats... Any ideas?

by

@macintek - since this Q & A are over 6 years old and the answer accepted. please start over fresh with a new question and let's make sure you get the attention you need as your symptoms are different.

by

Add a comment

Thanks a lot for that response !

I've checked the LEDs and when turned off my iMac has only LED1 ON.

When turned on, it has LED1, LED2 and LED3 ON...

Any additionnal clue with thoose datas ?

EDIT: I've tried to start the machine with the flat 27" screen unplugged and... mystery the 3 led's are still ON !

Wasn't the 3rd led supposed to be communication with screen ? I'm confused... any clue would be very very helpfull tranks !

Was this answer helpful?

Score 0

Comments:

led 3 is on ???

maybe the inverter isn't plugged in or is defective ? is the screen totally black when you start the iMac ? (tried a flashlight ??)

by

@Mayer : External monitor ? How could I do such a thing ? It don't thing it's even possible :s

by

The inverter I don't know but I indeed have run somme issues with the "synchronisation video cable"... Maybe it's juste that cable ? Whatever the screen is full black (even in the dark with a flashlight on it we can't see anything :s). As I said, due to a frien clumsiness when opening the iMac once, there was an "accident". The video connector on the motherboard was damage (I managed to fix it and It worked well for monthes) and the synchronisation cable as well (the connector was ripped, I cut it, softly scratched it and put some hard piece of cardboard and it worked as well). You know everything... any more clues ?

by

Hook up via the mini display port: http://support.apple.com/kb/ht3913

Use a Mini DisplayPort to either VGA or DVI according to the needs of your external display: http://store.apple.com/us/search?find=mi...

by

Yessss... the "trick" is working... When I plug an external monitor !

So what do you think ? Problems with the LED display ? Internal cable issues ?

Thanks a lot for all your responses ;-)

by

Show 1 more comment

Add a comment

Whin I had this problem i ended up changing out my backlight board and that made the screen go fro pitch black nothing on to blue everything is shiney and working. Not saying that is your problem, butt you can find some on eBay for around $40.

Was this answer helpful?

Score 0

Comments:

Tdog, great answer. hopefully this got fixed within the last four years since the question was asked:-)

by

The OP was just waiting ;-}

by

Add a comment

Add your answer

fpeliss will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 11

Past 30 Days: 36

All Time: 8,415