Fourth generation iPhone. Repair is straightforward, but the front glass and LCD must be replaced as a unit. GSM / 8, 16, or 32 GB capacity / Model A1332 / Black and White.

3169 Questions View all

Won't turn on, defo not the motherboard.

Hi, got an iphone that for the life of me I can't work out. Basically it was working perfectly, I left it on stand-by overnight and woke to find it off and not switching on...100% no water damage.

Anyway, left it on charge for a few hours with no sign of life, then all a sudden it took a photo itself and sprung to life. Battery level was 100% so I disconected it from the charger, 2 mins later it died again and wouldn't turn on...I bought a new battery and didn't work, tried holding the power button and home button but that also didn't do anything. When on charge (or connected to PC) its fine, so I restored and still no joy. I then began to think that Motherboard got damaged somehow so I nicked my wifes phone and swapped over motherboards to test, it worked perfecty just like it use to. ? (and my wifes Motherboard wouldn't work in my shell)

So..what do you guys think the problem could be ? I swapped batterys over and that didn't alter anything.

Thanks in advance for any suggestions...

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

to clarify, your mobo worked in your wifes shell but her mobo did not work in your shell?

if so than i would say there is a peripheral problem in your shell. try unpluging all connectors from your mobo except your dock connector. the power button will not work but if you plug in a charger it should power itself on. if it works then you got a bad cable to one of your peripherals. then you just have to do it one at a time until it acts up and when it does you will know which one is bad.

my guess is a water damaged charge port. id say 95% of iphones i work on have the charge port water damage indicator thrown.

Was this answer helpful?

Score 1

Comments:

Thanks PickleFish, took your advice and discovered that the power button flex cable was faulty. Ive put a new one in in its been fine for 24hrs. Thanks

by

Add a comment

Add your answer

Wurzel will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 5

All Time: 612