Backlight stopped working, but external video is fine

Hi! I've got a 1.2GHZ 12" G4 iBook, and the backlight has stopped working. It was fine, and I installed the OS with the bottom case and shielding off, and then I put the shielding and bottom on, and from that point on, the backlight will not work. External video shows up fine. I tried 3 known-good screen assemblies and screens (including good inverters, cabling, etc.) and none of them showed a backlight, although, again, a faint image is visible, and external video works fine. It almost seems as if I may have done some damage to the machine while putting the lower shielding on?

Lemerise, could this be a "logic board inverter circuitry" issue, and if so, is there anything that can be done?

Thanks!

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

I noticed that the little springy copper thing next to the inverter plug is broken off...could this be the microfuse that controls the backlight? I tried taking a tiny piece of copper and bridging the two ends of the copper connectors, but no luck. I think this is the right microfuse though...maybe I need to solder it?

by

Looking further into this, it seems the microfuse is not the copper springy thing, but more likely a tiny fuse-looking object just next to it. It doesn't look especially burnt out though, and even if it was, it's almost too tiny to tell, or to work with.

by

Success! I clamped both ends of the fuse with metal tweezers (probably at the risk or frying myself), and I got a backlight! Now I just need to figure out how to solder the two ends, since the plastic fuse mechanism is between the two posts and will make it tricky.

by

Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

Block Image

Was this answer helpful?

Score 3

Comments:

Good one. +1 Ralph

by

Awesome picture! That's by far the best picture I've seen. Unfortunately after all this, I think I killed the board by botching the soldering job. Very frustrating...I was so close to have it working, and then I killed it with my incompetence! Aaarrgh! The machine now has no video at all, either internal or external, although it seems to still boot up and function otherwise.

by

John, I think the best thing to do is to remove completely the microfuse and simply bridge the two contact points. That would close the circuit and restore electrical flow to the inverter socket. Be aware that this modification to the board leave it with no protection if there's a short caused by the inverter cable or the reed switch cable. When doing this repair make sure to replace the inverter cable before powering the machine. If someone could find a working microfuse and install it that would be better than simply bridging the two contact points.

Also there could be other damaged components in the inverter circuitry on the logic board so this repair will only work if the other components were not affected by the initial problem that caused the microfuse blow out.

by

Add a comment

Add your answer

rdklinc will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,321