New HD Install - Can't Boot From Disc, Can't run hardware diagnostic

Hi all! I followed the ifixit guide to upgrade my HD from the stock 100GB model to a new 500GB WD HD. I put everything back together, and now I can't boot from the original install disc that came with my computer.

I've tried a lot of things:

Booting while holding C.

Booting while holding Option.

(both nothing happens except eventual flashing ?)

Removing each RAM (have 2GB) and replacing each one at a time in to each slot.

Nothing happens when I boot while holding D, or anything else.

I can hear the superdrive working and reading the disc, but nothing on the screen changes.

In one iteration, I had one stick of RAM in, no boot disc. I held Option on boot and a black mouse pointer appeared and nothing else. I could move it all around the screen, but there were no drop down boxes, etc. Couldn't figure out what that meant...

How can I diagnose what exactly is wrong? Before the HD install, the computer worked.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Only you are aware if you damaged a connector or other component. Ensure that the RAM is fully seated (many people think they have installed RAM properly but it later turns out they hadn't "snapped" it in).

Try disconnecting the main power and battery, leave overnight. Reassemble and try again.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1

Comments:

Thanks Machead3 for the response. To my knowledge, nothing went wrong with the initial HD installation. I've replaced RAM successfully several times in this machine, and am confident that the RAM is "snapped" in place; I removed them and re-installed them this morning just to make sure.

I did as you said, and disconnected battery and power, leaving it overnight. I put it all back together this morning and still have the same issue. Upon holding "C" on boot, I don't get anything initially, but eventually a flashing question mark.

When I try holding Option on boot, same thing happens.

Any other ideas anyone?

by

Check the speed and backward compatibility of the new HD... 'you might be trying to run a SATA III drive on a SATA I system.

by

Add a comment

I have the same problem.. how Do you solve it?

Was this answer helpful?

Score 0

Comments:

Guillermo Bustos Cascante - For future reference you posted a Question in the place where only Answers belong. Please use the add comment link to the O.Q. or Answer. We need more information you didn't provide any details about your machine (id age) the OS (version) the new drive (manufacturer and model) or the Optical Drive. Any of those combinations could be your answer.

by

Add a comment

Add your answer

Camp will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 3

All Time: 534