iPhone 3G

Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1460 Questions View all

Phone freezes / shuts off when not plugged in

Hi folks,

So here's the issue I'm having:

the phone randomly (or seemingly randomly) freezes shuts off.

The only action that will bring the phone back is a hard reset (i.e. lock+home key held down for 10+ seconds).

The freezes / shut downs do NOT happen when the phone is connected to a charger - either wall or USB.

How do I fix this?

UPDATE: To clarify, I tried factory reset, restoring the phone from iTunes, etc. Nothing has worked so far.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I've seen other answers that indicate that this is a battery problem.

Was this answer helpful?

Score 0

Comments:

Would a battery replacement fix this?

by Vlad Bistriceanu

Most likley, but don't just take my word for it. Look around this forum for more info. But considering that a battery only costs 4.99 GBP, why not take a chance? Also! Since the phone 'works' (in the matter that the screen lights up, you see the Apple and that you can work on it - for a while), there's nothing wrong with the logic board... COULD of course be a memory problem (that's usually the case on computers), but for the price of a new battery and about half hour, an hour work, I'd spend the £5 Reading you post again, it is my opinion that it will defenatly be fixed by a new battery. "The freezes / shut downs do NOT happen when the phone is connected to a charger" That rules out the board, memory, harddrive, power switch and software. What's left is the battery... But don't sue if I'm wrong (it HAVE happened :).

by Turbo Fredriksson

Success!! I completely took it apart again. Removed the display assembly (but not separating this), mother board and sync connector. Cleaning everything by blowing clean, compressed air (from a aerosol can) in every nook and cranny and trying to get air in between the mother board and the RF sheilding from all directions, blowing everywhere on the back case and on and around the buttons (that where still in the case) and on all connectors (both on the mother board and on the flex cables). Then assembled everything again, making 100% sure that all the connectors where correctly seated. Turn it back on and loo and behold! Everything works like a charm!! I can turn it on and off, I can enter DFU mode and it doesn't reboot as soon as I unplug the sync cable!! Dang, I'm a happy camper now!! :D PS. Just in case this haden't worked, my next attemt would have been to spray/use some 'electronic cleaning solvent'.

by Turbo Fredriksson

Add a comment

Add your answer

Vlad Bistriceanu will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 6

All Time: 2,864