Home button does not work after replacement


This question is archived. No new answers are allowed, and only the question's owner may edit it.

My Verizon iPhone 4 home button was performing poorly: sometimes it would work and sometimes not.

Yesterday I replaced the home button and cable with an "iPhone 4 Home Button Assembly" from ifixit.com. The replacement went fine, though it was quite time consuming. After replacing all of the parts (the phone would not power on until I had put everything back) the new replacement home button is completely unresponsive.

I've tried reseating the new home button connector but it made no difference. I've also tried to measure the resistance on the four home button cable leads to compare the new and old buttons and they appear to behave the same, though the results were a little inconclusive due to the difficulty of getting my meter probes on the small pads. What I saw was that pads 1 and 3 and 2 and 4 appear as an open circuit, if you consider pad 1 to be at the top of this photo and 4 to be at the bottom:

iPhone 4 Home Button Assembly

When you depress the button, 1 and 3 short and 2 and 4 short.

Any suggestions, or confirmation of the expected behavior? I would like to avoid another complete disassembly (to restore the original button or install another new replacement) if at all possible?

Product Image

iPhone 4 Home Button Assembly

Includes the home button and home button cable to connect to the phone. Compatible with all iPhone 4 models: GSM (AT&T) and CDMA (Verizon). Black and white options available. — 50+ available at 9.95 each.

Edited by: iRobot ( )

Add Comment Cancel

Post Answer

Add Your Answer

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 549