Skip to main content
Question Closed

Flashing folder icon, HDD not found

Hi all,

I have az iBook G4 14" 1,33Ghz logic board, which can't recognise connected HDD. I've tried with two HDDs, and three different cables, but only flashing folder icon seen on LCD.

If I connected it trough firewire cable to another iBook running in targeted mode, it can be boot from the targeted hdd, it also can see an inserted install DVD from the targeted iBook, but when I want to install the OSX, the Hard Disk Utility only see the targeted HDD, and DVD.

I've formatted the test HDD in an iBook, so it couldn't be the problem.

My question is, which IC responsible for HDD control, and could it be replace. I have a few logic board with bad GPU for donor.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

You look like your facing two different problems:

I suspect you have a HD standards mismatch your system is Ultra ATA/100 compliant make sure you have the correct HD and the jumpers are correctly set. If you can't see the HD at all from the system directly.

Remember your system is a PowerPC based system so your choices of OS-X is limited! You can only install Snow Leopard 10.6.x or older.

A blinking question mark implies your system can't find a working OS on the local storage options it has (or the correct OS)

Was this answer helpful?

Score 1


The iBook HDD cable covers all the HDD pins (43+4) so I don't know where can I jumper it?

My HDD is a Fujitsu MHT2040AH PL, 40 GB, Interface DMA/ATA-100 (Ultra) formatted to Mac OSX journaled under a partly disassembled iBook G4 12".

I know that I could install only 10.5 (Leopard), 10.6 (Snow Leopard) runs only Intel based systems.

I know, that without installed system, i would see only a blinking question mark, but from booting a targeted iBook's install DVD, I could see the HDD, couldn't I ?


I've installed a 10.5.8 to the HDD in an iBook G4 12", put into the iBook G4 14", but the blinking question mark still remain. I've heared the spinning HDD, but nothing else.


The jumper is the master/slave setting it's not the I/O ribbon connector. Review this doc Look at page 3-12. Make sure you have the drive configured for Master.


Again, iBook HDD cable covers all the pins included A, B, C, D, there isn't room to put a jumper between the pins and the cable, otherwise on the 3-12 page, the figure 3-13 says that a master setting is when all of the A, B, C, D pins are open. More peciselly, the HDD is master without any jumper. Yesterday evening (as I described earier, I've installed a 10.5.8 system to this HDD in an iBook 12" succesfully. If I had to jumper the drive in any way it couldn't worked.


Correct! the Master is with no pins shorted. Not all of the cables that came with this system covered the pins and some HD's have the master/slave jumper at other locations so you have to hunt for it to make sure. - You state you have been able to install Leopard and it boots up now? Master/Slave setting won't stop you from installing the OS, but, it will mess up the boot order.


Show 12 more comments

Add a comment

So, the situation is the following:

I have a full working, assembled iBook 12" 1,2Ghz system with Leopard.

I start it pressind the 'T' button, till the firewire icon appears.

I have a disassembled iBook 14" with an 1,3Ghz logicboard.

If I connect it through firewire cable with the 12" iBook, and switch it on pressing 'option' key, I see the 12" iBook HDD, and DVD.

BUT! If I plug a HDD (installed a Leopard on it) to the 14" logicboard, it couldn't recognise it.

If I connect the HDD (installed a Leopard on it) to another iBook, it will boot, so the HDD is OK.

MAX GR today suggested me the following troubleshooting:

"- Hard Drive not detected, optical drive detected

Connector of the Hard Drive or the Laptops interface may be damaged. Insert Hard Drive into another computer to check to see if the Hard Drive works. If it works, the Laptops interface may be broken. If it doesn't work, replace the Hard Drive or use the one from the iBook 12" "

So, I pick up a working DVD, plugged it to the 14" iBook logicboard, and it worked! I could load an install disk with it. Unfortunatelly the plugged HDD still won't be seen.

In that case, the "Insert Hard Drive into another computer to check to see if the Hard Drive works. If it works, the Laptops interface may be broken." case happened.

Otherwise the HDD connentor was suspicious, because the cable plug comes out very easy from it, and I could hear noise from HDD only when I press the plug.

I hope, that if a controller chip can handle firewire, optical drive, the HDD controller part should also working.

In this case, I only need to replace the bad connector, needn't I?

Was this answer helpful?

Score 0


I've changed the connector, but iBook still won't recognise HDD. But another problem comes out, DVD ejects all disk immediatelly...


The Dvd player was bad, with another it can read those Dvd.


First I would verify your machine has enough RAM. If there's no expansion RAM, and the machine has only 256MB onboard, it's possible it doesn't have enough to boot the OS and will show the blinking folder even thought it has a bootable OS. Probably not the issue, but worth mentioning. Leopard will typically boot even if a machine only has 256MB, but sometimes not.

What happens when you put this machine into option mode? Does it go into option mode, or do you by chance see a picture of a padlock? If you see the lock, you've got a PRAM password, and that could account for not booting to the internal drive, and can be fixed with a hard PRAM reset. Even if option mode does come up, it's probably worth doing a PMU reset, as well as a hard PRAM reset (change the amount of RAM in the machine, then immediately reset PRAM 3 times beyond the additional chime).

I have run into iBooks that have power issues and for some reason will only power one device on the IDE channel, and the other won't be visible. To test for this condition, I would disconnect the optical and see if the machine then recognizes the hard drive. If it does, then your board is likely bad. If it still doesn't recognize the hard drive -- assuming as you say that the hard drive is known-good, and the hard drive cable is known-good, and you've done all the resets and steps I listed above -- I'd say the board is bad in that case as well. Unfortunately there are some board issues out there that don't have a fix, or at least aren't worth pursuing a fix, due to the low value of iBooks these days.

All the stuff above about dip switches, the wrong type of hard drive, installing different support files, selecting the boot device -- none of that is really relevant or going to be the issue. The fact that your drive works on another iBook rules all that out, and resetting the PRAM rules out the boot device issue.


In the option mode I can see a circle arrow and a straight arrow pointing to right. No padlock can be seen. I started the logic board in open firmware mode several time and try reset-nvram, reset-all commands without any result. I've also insert a + 256MB module into it so it could boot with 512MB RAM.


Add a comment
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,919