13" aluminum unibody, 2.0 or 2.4 GHz Core 2 Duo processor.

574 Questions View all

Battery Is Not Charging

I just bought faulty mac from ebay, and trying to restore it.

I just tried to launch it without battery, and it was ok. after I bought new battery, and installed it, Its working fine, but have problem with charging.

Actually problem is: no any lighting(orange or green) on Magsafe connector and OS indicating "Battery Is Not Charging" but charger charging battery very slowly.

I already tried to reset SMC and PRAM with no success.

May be there is some solutions at this case?

Probably I bought faulty charger or MagSafe logic circuit?

There is some info about Power in my system:

Battery Information:

Model Information:

Serial Number: W011858G7D3LA

Manufacturer: SMP

Device Name: bq20z451

Pack Lot Code: 0

PCB Lot Code: 0

Firmware Version: 201

Hardware Revision: 000a

Cell Revision: 165

Charge Information:

Charge Remaining (mAh): 1685

Fully Charged: No

Charging: No

Full Charge Capacity (mAh): 5812

Health Information:

Cycle Count: 2

Condition: Normal

Battery Installed: Yes

Amperage (mA): 103

Voltage (mV): 11334

System Power Settings:

AC Power:

System Sleep Timer (Minutes): 10

Disk Sleep Timer (Minutes): 10

Display Sleep Timer (Minutes): 10

Wake on AC Change: No

Wake on Clamshell Open: Yes

Wake on LAN: Yes

Current Power Source: Yes

Display Sleep Uses Dim: Yes

PrioritizeNetworkReachabilityOverSleep: 0

Battery Power:

System Sleep Timer (Minutes): 10

Disk Sleep Timer (Minutes): 10

Display Sleep Timer (Minutes): 2

Wake on AC Change: No

Wake on Clamshell Open: Yes

Display Sleep Uses Dim: Yes

Reduce Brightness: Yes

Hardware Configuration:

UPS Installed: No

AC Charger Information:

Connected: Yes

ID: 0x0000

Revision: 0x0000

Family: 0x0000

Serial Number: 0x00000000

Charging: No

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Have you tried a second charger yet?

by

yes, today I been in Apple Store and tried to connect L-shape charger, and it had green light on connector, but had same problem "Battery Is Not Charging

"

system power information was shown same description. in my opinion its looks like system dont recognising charger.. Which component or circuit is responsible for it? it can be Magsafe DC-IN BOARD Power?

cheers!

by

Add a comment

1 Answer

Chosen Solution

At this point you'll need to open the system up to see whats up.

The DC-in board is mostly passive in this model (very little circuitry). The underside of main logic board near it has most of the battery control logic.

Look for liquid damage or a burn't component on both boards.

Make sure you follow proper ESD practices. Good Luck!

Was this answer helpful?

Score 1
Add a comment

Add your answer

Alexander Letetsky will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 7

Past 30 Days: 22

All Time: 2,975