Power Button Not Working.

My Samsung Galaxy S2 (AT&T) is rooted, and I am running a custom ROM. It worked great for about 7 months, but yesterday my phone would randomly reboot when I would press my power button. I thought it was either the custom ROM or my power button was stuck so I installed a new custom ROM to see if that was the problem was software related. After I installed the new ROM the power button worked great, but this morning my phone would only unlock when I plugged it into the AC or when someone called me (The power button is not unlocking/locking the phone). I've tried to boot into Recovery, but I need the power button to reinstall a ROM and it's not working there either. I've done some research and one guy said it may have overheated and to let it sit without the battery for a few hours so this is what I'm doing now. However, I think I've come up with the conclusion that my power button is broken, and if this is the case I could use some help on how to fix it because I'm not skilled with phone hardware. Any help is appreciated, and if I find anything else that helps then I'll be sure to post back that my problem is fixed and what I did to fix it.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment