Skip to main content

Model A1013, A1052, A1085, or A1107 / 1440x900 screen resolution

121 Questions View all

OS 10.3, 10.4 or 10.5 won't install on a reformatted disk... HELP

Have a Powerbook G4 17" with 2G RAM, 80G hard drive, 1.67GHz... my son deleted the system folder and now the machine will not boot up.

So I tried an original Powerbook G4 install disk* at start up holding down the C key but the disk was ejected. Then the folder with question mark and flashing mac icon showed up. *(PowerBook G4 15-inch and 17-inch Software Install and Restore. Mac OS Version 10.3, AHT Version 2.0.6, DVD Version 1.0, 691-4703-A)

Then I tried same as above with original PowerBook G4 install disks for a 15 inch*. These install disks come as a pair disk 1 and disk 2. The second disk includes Mac OS 9.2. but I never got to install since the first disk was ejected like the one above. *(Install disk 1 Mac OS version 10.4, AHT Version 2.5, Disk Version 1.1, 2Z691-5517-A, 2005)

Then I Firewired the 17" into my 15" making the 17" the target disk and reformatted/erased the 17" drive using Disk Utilities from the 15". Tried again to install as detailed above but got the same results... Start machine, holding down C, insert disk, hear the drive engage, then eject and the folder with flashing ? and icon appears.

Then I bought an original retail, full install version of Leopord 10.5, Install DVD, 2Z691-6038-A, 2007 and tried to install that but got the same results as above.

So I tried copying over from the 15" to the 17" system and library then restarting the 17" but of course that didn't work. I then reformatted and erased the 17" and have retried all the above PLUS holding the Option key down on the 17" while starting up.

While holding the Option key at start up the screen came up with the stop watch which circled for about 20 seconds before the pointer and two option buttons appeared, one button to go forward and one to re-circle what I presume is the previous operation. I tried to click the forward button but the pointer disappeared. So I restarted again, same scenario only this time the pointer held and I clicked the forward arrow. Nothing happened. I clicked it again, nothing. I tried clicking the circular arrow and nothing there either...

I am out of ideas. The CD hardware was working fine prior the OS being deleted. And it sounds like it reads the disks then spits them out. Disk Utilities hasn't given me a hardware problem in regards to a faulty CD player but then I don't know if I have tested for the specifically. The Hard Drive has been successfully reformatted a couple of times now... why won't an OS load on this 17"???

Answered! View the answer I have this problem too

Is this a good question?

Score -1
Add a comment

2 Answers

Chosen Solution

You maybe facing a rev difference between the HD's I suspect your newer drive supports the newer UltraATA/100 standard and the other UltraATA/80. Depending on which system you have which drive in (assuming you swapped the drives around) you may encounter compatibility issues.

You can also try updating the firmware on your systems PowerBook G4 Firmware Update 4.2.9 This may also help.

Was this answer helpful?

Score 1
Add a comment
Most Helpful Answer

Try repair harddrive / first aid on the drive.

Try using another computer to copy the disc to usb and try booting from that. It's hard to tell without being in front of it.

Was this answer helpful?

Score 1

1 Comment:

thanks - but I swapped a CD/DVD superdrive out of a second Powerbook G4 we have laying around. The original problem was simply a bad drive. The faulty drive was dated 2006 - the fully functioning drive labeled 2003 - go figure.


Add a comment

Add your answer

ncnet will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 722