Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

778 Questions View all

Bizzare Display malfunction, can anyone help please?

Hello, so a few days ago, my Macbook 2009 Unibody 2ghz started doing this (I posted a Video of it on youtube):

http://www.youtube.com/watch?v=FJgwxOkRU...

The macbook boots fine, works fine, even the display, until i start flipping the lid. As soon as there is a minor movement, the screen starts to fade. At the next startup, everything is fine again.

Can anyone help me, or tell me how i could fix this? (I know how to dissasemble the display ;))

Thanks for your help, I really appreciate.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

It must be something with the display cable, look at step 8 on the guide:

MacBook Pro 13" Unibody Mid 2009 Display Replacement

Something similar happened to me with a dell, the data cable had an issue and it would make the display go crazy in colours.

Was this answer helpful?

Score 1
Add a comment

I agree.

Typical of a broken video cable in the hinge.

You can see the artifact column on the left as you are touching it and then the signal is inverted once you push it farther back.

Question is if one can order & replace the cable itself, without the screen? As the assembly is $$$.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Thierryl will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 226