MacBook Pro charges but won't power on after replacing DC board

The power adapter that came with my Mid-2010 MB Pro 13" (A1278) was playing up and eventually the cable separated from the L-connector. At the time I did not have an Apple reseller nearby, but I did have a soldering iron handy so I fixed it. It worked like a charm for almost 6 months.

Then last week the same problem, the power adapter stopped charging the laptop and when I pulled the cord a little stronger the whole thing came apart again (my soldering probably wasn't all that great!). I think I heard it sparking just as I pulled it - I am guessing that this is when the DC board was damaged.

This laptop is one of two machines I use constantly for work, so I HAD to get some files off it. I connected the laptop to my iMac in Target Disk Mode and started transferring files, but after a few minutes the battery died (it hadn't been charging earlier). I didn't try launching it again knowing that there was very little charge left there. The battery charge indicator would blink fast when button was pressed so I am guessing the battery wasn't 100% drained.

I went out and bought a new power supply (60W, I checked the old supply, checked on the Apple site and asked at the store whether this was the right one) but the laptop wouldn't charge - no amber or even green light.

I took the adapter and the laptop back to the store and they said it was either the DC board or the motherboard. So having read tons of answers (that was one fun Friday evening...) on iFixit and other usual places I thought it must be the DC board - I was able to shut it down normally and then start it in Target Disk Mode after all. This probably wouldn't have been possible if the mainboard was affected.

I ordered a DC board, it arrived today and I replaced it. Was very careful, no static, yadda yadda yadda. Took my time with it and made sure I connected everything correctly. When I put the laptop back together the green and then amber light came on. I let it charge for 30 mins or so, until 2 out of the 8 battery level indicator LEDs were on and tried powering it up - no luck. Nothing. I let it charge up to 100% and tried again. Nope.

So I tried resetting SMC and NVRAM (I am clutching at straws here!), tried disconnecting the battery and starting with only the adapter connected. Nothing.

There was never any water damage on the laptop so I did not try kickstarting the mainboard (yet).

Is there any way to check what is not working? Normally I would say the mainboard needs to be replaced, but the laptop worked fine until the battery ran out. Could the fact that the battery died during file transfer in target disk mode have wrecked the mainboard? Can I disconnect any cables and try launching without them? I have a simple multimeter so I guess I can check the voltage here and there if I know what to look for.

I know similar questions have been posted and did not get any answers but maybe I'll be more lucky? :)

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Go over all your connections, especially the ribbon cable connector. Carefully using the How to disable internal keyboard and make the POWER button works? would bypass top case/ribbon cable problems and let you know if the logic board is at fault.

If this answer was helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 3

Comments:

Reseating the keyboard ribbon cable did it! Thank you VERY much, machead3. The cable was not slid all the way in. I did not realize that 0.5-1 millimeter could make a difference - I was sure I had inserted the cable properly.

by

Add a comment

Add your answer

Peter Parzysz will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 1,766