Model A1200 with 2.16 or 2.33 GHz Core 2 Duo processor

123 Questions View all

Why does my optical drive has no electrical power?

I upgraded my iMac 24" Intel Core 2 Duo, 2.16 GHz processor with 2 GB memory with new optical drive. Yet when I powered up the iMac the optical drive had no power and not recognized by computer. I double checked the power and ribbon connector and seemed to be in place. I replaced the old drive that was working before removal and it did not work either..... what should I troubleshoot for in this reinstall?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Just to be clear here the original player had stopped working which is why you put the new on in. Since then you tested the older player and you found it was OK. If this is correct you likely have a power supply problem. With a volt meter check your 12 volt lines from the supply I think you'll find they are dead.

by

Thanx for responding Dan. I upgraded the old drive that was working at the time of removal. I installed the new drive and had no electrical power to the drive. Troubleshooting, I reinstalled the original apple drive that was working before removal and it too had no electrical power. Could it be a defective drive plug and ribbon connection?

by

Dan, thank you for responding. I did exactly what you said... pulling the ribbon cable without releasing the plate. I released the plate to reinsert the ribbon cable but had to pull from the socket to try again. Upon releasing that very delicate plate it came all the way out of socket and broke the right side release tab... so I'm in a little pickle now and a little frustrated...because failing is not an option for me. Is it possible to replace that release plate/or is buying a external optical drive/burner the only real option now?

by

Sorry to hear the connector is broken. Yes, you could use an external CD/DVD player or burner the I/O will be slower than the internal unit. Make sure you get at least a Firewire case for your DVD unit you bought, if you can wait a bit you might find a Thunder Bolt unit which would be ideal if you have a newer iMac that has a TB port. USB will be the slowest (USB 2.0). Apple is starting to roll out USB 3.0 on the newer Mac's but I don't know if any of the USB 3.0 burners/players have the needed Mac drivers yet (and that doesn't help you here). Lastly, put the older optical unit back in and bring it in to a Apple Store genius bar. I wouldn't tell them anything other than the unit stopped working (limit what you say, don't lie if they ask). See what they tell you the cost of repairing your system. Good Luck!

by

Add a comment

1 Answer

Chosen Solution

I guess the first Q is why did you replace the working player in the first place?

I'm assuming you have the iMac A1200 with 2.16GHz Core 2 Duo processor. Review this guide (IMac A1200 - Optical Drive Replacement) If this is not what you have you'll need to supply us the last for digits of the serial number so we can isolate out which model you really have.

If you are sure the player worked and when you put it back in it didn't, it sounds like you damaged the connector on the cable side. Look at the second drive are any of the pins damaged or missing? Also double check the original drive as well for any damage (the pins are so small it doesn't take much to break/bend them) . If you find no damage you either damaged the cable or the ZIF socket on the main logic bd.

The lines & contacts are so small you really can't trace them out directly on the cable, it's just easier to replace it. Hopefully you didn't damage the ZIF connector.

Was this answer helpful?

Score 1

Comments:

Again, thank you for responding to my problem. Dan, I called my self upgrading to a faster drive by replacing a perfectly working drive. Thank you for the "Installing link", one I could not find. I noticed on Step 14---Gently pull the cable retainer on the optical drive ZIF socket....I don't recall performing this function so I will see if that's the problem. Do you know where to buy a new cable? I appreciate your time and help.

by

Pulling the cable out of the ZIF connector without first releasing the pressure plate is more likely to hurt the connector than the ribbon cable. If your lucky, releasing the plate and re-inserting the ribbon and resetting the plate might solve your problem. If not check the ribbon for damage and if you don't find any its' likely the connector contact has become damaged. Good Luck!

by

Add a comment

Add your answer

Fred will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 460