How to fix a [NAND] screen when the iPhone is booting?

Hello, i have a problem with my iPhone 4s. At first it was showing the iTunes logo and i wouldn't pass the restore. Then i putted in "DFU mode" and it passed it. Then when the restore finished, the iPhone kept on rebooting it self. After a while i rebooted one more time, but now showing kind of verbose boot.

showing this:

  • [NAND]_FindFlashMediaAndKeepout :572 physical nand block offset 1
  • [NAND] start :343 this 0x81c0e900 PROVIDER=0x81c04c80 flashMedia=0x81c84c80
  • [NAND] WMR_Start : 145 Apple PPN NAND Driver , Read/Write
  • [NAND] WNR_Start : 170 FIL_Init [OK]
  • [NAND] WNR_Open : 367 VFL_Open [OK]
  • [NAND] WNR_Open : 410 FIL_Open [OK]
  • [NAND] _ppnvflGetStruct :3239 Checking borrowed blocks - count: 44 max_count: 44
  • [NAND] _fetch BorrowedList:789 number of borrowed blocks 37

looking like this:

And it won't pass that. I also tried a hard reset (Pressing Home, and Power buttons) But it will just stay on the apple logo. (I tried resetting the device several times and still showing the same thing)

Any suggestions? If there is a hardware problem, could you please tell me what it is so i can fix it?

Answer this question I have this problem too

Is this a good question?

Score 0


looks like part of the bootloader. Have you tried DFU mode and a restore?


Same issue with [NAND] messages stuck in boot screen on my iPhone 4s after dropping in water.

Solved this!

1. Quickly shut down.

2. Use manual to open up and disassemble.

3. Did every step and stopped when the logic board was out of the iPhone.

4. Then dried everything with clean tissues.

5. and waited for a day.

6. cleaned all connectors with alcohol and clean tissue.

7. Especially the front camera ribbon connector.

8. Reassembled carefully

9. Works like a charm


Add a comment