Model A1288 / 8, 16, or 32 GB capacity

579 Questions View all

I have a photo of a usb and itunes icon on screen

Recently my son dropped my iPod Touch 2nd gen in to the dogs water bowl i fished it out as soon as it literally hit the water, I have kept it on a dry underfloor heated room floor to dry as best as I could, it seemed to work unfortunately the battery then 'died' so I charged it after 2 days being dried and now i have a picture on the screen of a USB cable going to iTunes, I tried going on there but had a notice to say as I have password protected he iPod I cannot access iTunes. I then tried the resetting of it and this does not seem to work, can you help?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

michelle mills, one of the things you will have to do, is to clean the iPod. It is easily possible that you will end up with corrosion failure if you do not clean it. Here is a great guide for the iPhone, it will apply to your iPod as well. Use these guides to work on your iPod. After that, replace the battery. Once cleaned, and a new battery installed, reevaluate. You can try to place your iPod into DFU and restore from there. It will not matter if you have it password protected, it should still restore. Here is a good explanation on how to get your iPod into DFU. Hope this helps, good luck.

Was this answer helpful?

Score 1
Add a comment
Most Helpful Answer

How did you do the resetting? I found this video, maybe it can help.

By resetting it, you would loose all data stored in your ipod.

http://www.youtube.com/watch?v=hnp_eLoxf...

Was this answer helpful?

Score 1
Add a comment

Add your answer

michelle mills will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 539