Model A1288 / 8, 16, or 32 GB capacity

585 Questions View all

Music won't play, I push "play" but it just returns to pause.

I've restored the iPod touch, and tried many songs that are good on other iPods. It's weird, as soon as I hit play on the screen, it immediately returns to pause and won't play at all.

any ideas?

Answered! View the answer I have this problem too

Is this a good question?

Score 3
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

4 Answers

Chosen Solution

Here's Apple discussion board on the problem with 30 people with the same problem. A couple of successful resolutions, nothing absolute. You might want to get on this board.

Headphones and jack would be my best bet.

Was this answer helpful?

Score 2


No, thats when the music is playing and it randomly pauses. I know what hes talking about I just had the same problem. I reset it, restored it, everything i could think of but still wouldn't play. When I added some new songs to my iPod, it started working again.


Add a comment

I recently switched my AppStore from US to Canada. When I switched it back, the music started working again! To switch it back easily, just search on google for the dominoes USA app, and click it. When you do that it’ll ask to switch back to US AppStore. Worked for me :)

Was this answer helpful?

Score 1
Add a comment

my ipod does the same thing. I hit play it does not play at all it goes straight to pause. please help.

Was this answer helpful?

Score 0
Add a comment

I had the same problem with my ipod touch 4th generation. Push play and it would pause and would not play any audio. I rebooted, turning it off and waiting a few minutes and turning it back on. That fixed the problem.

Was this answer helpful?

Score 0
Add a comment

Add your answer

iTronics Repair will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 32

Past 30 Days: 205

All Time: 25,366