Touch screen isn't working


I've recently drown my new Atrix for a few seconds (4 maybe) in shallow water (1"). I've completely disassembled it & dried it.

The phone works OK, 3G, Wifi, screen, USB,... anything but touchscreen. When I first assembled the phone touch didn't work. So I've disassembled it and reassembled it a couple of times 'till it worked. Two days later it stopped working again, so I've redone the work, and it worked again. Then I've tried leaving the phone off without the battery for a couple of hours and when I turn it on, it worked. Seems that when it's on and I reboot or turn it on after a couple of minutes of being in use, touchscreen doesn't work. This was untill the day before yesterday. Now I can't make it work. No matter how many hours I leave it.

I've checked all the components and the touch screen module seems to be ok (at least from a simple visual inspection).

Also I've taken it to a technician and he did a thermoclean of the unit with no luck.

He thinks that the touchscreen isn't failing because touchscreen either works or not.

What do you think? Any advices? Do you think that the problem is the motherboard?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment