iMac Intel 20" EMC 2105 and 2118

Model A1174 with 2 GHz Core Duo or Model A1207 with 2.16 or 2.33 GHz Core 2 Duo

246 Questions View all

upgraded CPU and now no power

So I took the plunge and upgraded the CPU from 2.0Ghz core duo to 2.16ghz core 2 duo. Now I have no power and all that happens when I hit the power button is the light blinks once, shuts off and nothing happens. I have reseated the memory many time and I have even completely taken it apart and tried a second CPU of the same specs and still get the same issues.

Does anyone have a clue what could be the issue?

My last resort would be to take it apart again and put the old CPU back in to see if it boots and I didn't fry the board at some point.

I was really careful and even cleaned every thing out with a compressor because the thing was disgusting with dust build up.

Any help before I take a 3rd plunge would be appreciated.

Answered! View the answer I have this problem too

Is this a good question?

Score 0


So I may have figured out my problem. I am using a t5850 processor 2.16ghz. It fits in the socket with no issues but it may not be compatible. Can someone please confirm this that may have tried the upgrade? thanks again,

by sold4money

Add a comment

2 Answers

Chosen Solution

AFAIK you have to "upgrade" to a CPU used or "offered" by Apple... the EFI firmware won't support anything else. See this previous Question and Answers.

If this answer was helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 0


This didn't really help but thanks for trying.

by sold4money

Add a comment
Most Helpful Answer

Run through my answer here and see if it helps:

Was this answer helpful?

Score 1
Add a comment

Add your answer

sold4money will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 677