Skip to main content
Help

Original post by: Robert ,

Text:

Okie Magic works again!

I took it apart and checked the DC-in and logic boards for corrosion, burnt parts and such. Nothing. Cleaned  VERY thoroughly around the MagSafe connector on the computer. Also  scrubbed the pins on the charger side of the MagSafe and ran some  alcohol through the spring-loaded pins. One of the pins seemed maybe  slightly sticky? [br]

During reassembly I saw a  slightly oily film near the AirPort card (separate from the logic  board). Took off the AirPort card and there was some similar fluid under  that on the ''non-absorbent'' foam pad on the underside of the card. Cleaned that all up. Got  it all back together, fired it up and it worked just fine. I have NO  idea what I might have fixed or not fixed. System profile software says  battery isn't even to 1,000 cycles yet and is in good condition. Problem  solved, no idea exactly why, but can't argue with success. Better to be  lucky than good.

Thanks all for your help and for being on this forum to help us less talented folks.

Status:

open