Skip to main content
Help

Original post by: Andrew Stanley ,

Text:

I had this problem when replacing 4 OEM 16 sticks  with 4 OWC 32 sticks.  The machine booted 1x and after that, black screen booth.  tl; dr:  I solved this by permuting all of the possible combinations of sticks after labelling them 1-4, based on that 1x boot order.

I could get things to work with up to 3 sticks (1, 3, 4 and 2, 3, 4), but never (again) all 4.  Slot 2 was the most problematic, because I could only get it to boot with certain chips in Slot 2.  If I mixed in ANY combination of OEM chips, with Slot 2 always filled by a OEM stick… the machine booted just fine

So, I did a SMC reset and PRAM reset.  Didn’t work.  Checked that the sticks were flush after re-installing the carrier every time.

After it worked (fleetingly), I assigned each stick a #, 1-4, based on which slot they were in.

So, I called OWC.  We agreed that the best way to pursue this was to cycle sticks to see if there was any way to get it to boot.  He suggested that I do a return and start over again, but my stubborn ass wouldn’t let it go.

I then hunted around the slots.  I started with which sticks would boot when installed in each of the slots.  For me, my stick 1 worked in slot 1 and in no other slots.  I repeated this for the other sticks, finding that stick 2 worked in slot 3 and four, but never  2.  Stick 4 always worked in Slot 2.  I used that as my anchor…

Then I checked how the other sticks  behaved.  I found that I could boot on Stick 1 -> S1, Stick 3 -> S3, and inverse.  Stick 2 -> S2, Stick 4 -> S4 never booted again, but Stick 4 -> S2, Stick 2 -> S4 always booted.

Finally, I went with my Stick 1 / Stick 3 pattern, eventually getting a boot (after about 15 seconds) out of the 3, 4,1, 2 pattern.

I have rebooted a bunch of times and completely cycled the power, including disconnecting the power at the wall.   I have not done a PRAM reset as of yet.  I’ll report back to OWC and here if things get messed up again.

Status:

open