Skip to main content
Help

Current version by: oldturkey03 (vote details) ,

Title:

After replacing digitizer and screen, partially working

Text:

I ordered digitizer and glass replacement for Touch 2g from Amazon.  After replacement and reassembly the screen showed battery icon when plugged in.

The screen is responsive, mostly.  There is a portion of the screen, about a strip 2/3 from the left side, that is a "dead spot".  When I swipe the lock it always drops back at that point.  I have to swipe it fast several times before it will pass that point and unlock. I am unable to reset the date in the "date and time" because it will not move/scroll, but the month and year are movable and i can change them fine.

Basically, most of the screen works except what seems to be one strip/section.

Q) did i do something wrong during installation? or did i just get a digitizer with a bad section?

Device:

iPod Touch 2nd Generation

Status:

open

Accepted Answer:

67629

Original post by: Jim ,

Title:

After replacing digitizer and screen, partially working

Text:

I ordered digitizer and glass replacement for Touch 2g from Amazon.  After replacement and reassembly the screen showed battery icon when plugged in.

The screen is responsive, mostly.  There is a portion of the screen, about a strip 2/3 from the left side, that is a "dead spot".  When I swipe the lock it always drops back at that point.  I have to swipe it fast several times before it will pass that point and unlock. I am unable to reset the date in the "date and time" because it will not move/scroll, but the month and year are movable and i can change them fine.

Basically, most of the screen works except what seems to be one strip/section.

Q) did i do something wrong during installation? or did i just get a digitizer with a bad section?

Device:

iPod Touch 2nd Generation

Status:

open