Skip to main content
Help

Current version by: Jaime ,

Title:

Magsafe green. No int. mechanical sound, startup chime or sound/video

Text:

Hi all,
-Any help greatly appreciated. I tried powering on without battery by unplugging the magsafe, holding power button for 10 seconds, replugging magsafe while continuing to hold for another 10 seconds, then letting go and trying to power on again - but no go.
+Any help greatly appreciated.
-No sound or video or startup chime. No internal “whirring” sounds heard either. Have tried the same RAM and Hardrive (with El Capitan installed) on another MBP and it works.[br]
+MODEL: MacBook Pro 15-Inch "Core i5" 2.53 Mid-2010
-[br]
+PROBLEM: Magsafe green but unit won’t startup. (No int. mechanical sound, startup chime or sound/video)
-Thanks in advance for any advice!
+I tried powering on without battery by unplugging the magsafe, holding power button for 10 seconds, replugging magsafe while continuing to hold for another 10 seconds, then letting go and trying to power on again - but no go.
+
+No sound or video or startup chime. No internal “whirring” sounds heard either. Have tried the same RAM and Hardrive (with El Capitan installed) on another MBP and they both work fine. Thought it was a dead battery but the above trick without battery didn’t work so haven’t isolated the battery as the problem yet. Any advice here is greatly appreciated and thanks in advance:)
+
+Jaime

Device:

MacBook Pro 15" Unibody Mid 2010

Status:

open

Original post by: Jaime ,

Title:

Magsafe green. No int. mechanical sound, startup chime or sound/video

Text:

Hi all,

Any help greatly appreciated. I tried powering on without battery by unplugging the magsafe, holding power button for 10 seconds, replugging magsafe while continuing to hold for another 10 seconds, then letting go and trying to power on again - but no go.

No sound or video or startup chime. No internal “whirring” sounds heard either. Have tried the same RAM and Hardrive (with El Capitan installed) on another MBP and it works.[br]

[br]

Thanks in advance for any advice!

Device:

MacBook Pro 15" Unibody Mid 2010

Status:

open