Skip to main content

Fix Your Stuff

Right to Repair

Store

Help

Original post by: Alf Pogs ,

Title:

WD My Passport showing up in device manager, not disk management

Text:

I have searched for and looked through many questions and answers but haven’t found a solution to my issue which seems really specific. I have a WD My Passport Ultra 260D that’s only about three months old and it stopped being recognized a few days ago, while it was still plugged in.  It shows up in Device Manager under disk drives and also shows the WD Drive Management devices. If I right click the drive to show  Properties it will say it is working properly, the driver is updated, but if i click on the Volumes tab it doesn’t recognize anything, and when I click on the Details tab, the Properties window freezes completely as well as the device manager window.

I tried uninstalling it thru the device manager but that didn’t do anything and just stayed running indefinitely. Trying to eject the drive with the tray icon doesn’t do anything.

It doesn’t show up under Disk Management so I can’t try the partition solution that has worked for some people. I tried downloading the MiniTool Partition Wizard and it’s not recognized there either.

I’ve tried different cables, ports, and a different computer (both running Windows 10). I tried plugging it in halfway and that didn’t work. It’s not making any clicking noises or anything.

Please help me this problem is stressing me out so much and making all my muscles tense I just want to access my stuff!!!!!!

Device:

Western Digital My Passport Ultra

Status:

open