Skip to main content
Help

Original post by: Klazz Karrye ,

Text:

Hi, I know this is a really late answer but it might help.

I was having the same problem of only hearing interference and not even hearing the “power-on” when pressing the power button, not only that but the sound from the AUX cable sounded sort of scratchy (almost when an AUX chord doesn’t work properly) when connected to my laptop. What I did was connect it to another device (in my case my phone) with the AUX cable and although at first it didn’t connect, after connecting it a few times, the headphones started working properly, both with the AUX cable and on Bluetooth.

To be honest I don’t know what might have been or why they fixed themselves but it worked for me, so it might work for you.

For more context, I tried using them on my gaming PC (which doesn’t have a mic and I can’t get any mic to work on it) but they didn’t really work, and they sounded scratchy there too. After that, the problem from above started.

TL; DR: I connected them to another device in which they worked fine before and they started to work again. (I had done the ‘+’ and ‘-’ reset a few times already.)

Status:

open