Skip to main content

Fix Your Stuff

Right to Repair

Store

Help

Current version by: Oliver ,

Title:

Battery is not detected. Green light on MagSafe

Text:

Hi All.
 
I have a green light on my MagSafe charger but the MacBook will not detect the battery. I have 2 batteries and another MacBook which I have tested the batteries in. Once charged up in the other MacBook the batteries are able to power my A1342. The batteries are still not detected though.
 
Judging by the fact that the batteries can power the A1342 laptop i’m guessing the battery SDA and SCL lines might have an issue. I have a schematic but no board view. Where should I be looking on my logic board for damage and what could the issue be? Looks like there may be some in line fuses on the SDA and SCL lines. I also see a SYS_Detect line but I think this just tells the battery its connected to a laptop.
 
SMC has been reset a couple of times and I have reset the PRAM for good measure.
 
Any advice would be great - I don’t think the system has any water damage although I haven’t always been its owner.
 
I have attached a screenshot below of the System Information application showing this issue in the Power tab.
 
O.
 
[image|2117370]

Device:

MacBook Unibody Model A1342

Status:

open

Original post by: Oliver ,

Title:

Battery is not detected. Green light on MagSafe

Text:

Hi All.

I have a green light on my MagSafe charger but the MacBook  will not detect the battery. I have 2 batteries and another MacBook which I have tested the batteries in. Once charged up in the other MacBook the batteries are able to power my A1342. The batteries are still not detected though.

Judging by the fact that the batteries can power the A1342 laptop i’m guessing the battery SDA and SCL lines might have an issue. I have a schematic but no board view. Where should I be looking on my logic board for damage and what could the issue be? Looks like there may be some in line fuses on the SDA and SCL lines. I also see a SYS_Detect line but I think this just tells the battery its connected to a laptop.

SMC has been reset a couple of times and I have reset the PRAM for good measure.

Any advice would be great - I don’t think the system has any water damage although I haven’t always been its owner.

O.

Device:

MacBook Unibody Model A1342

Status:

open