Skip to main content

Original post by: JChris ,


I have this exact issue with a MBP13 Late 2013. I won't open a new topic because it's very similar. I have a MBP13 Late 2013 that worked flawlessly until recently when sound stopped working. Events are as follows:

# MBP13 was running macOS Mojave and updated to Catalina some weeks/months ago. I didn't notice any issues, but some days/weeks after the update, while watching YouTube, the MBP suffered a kernel panic related to '''coreaudiod'''. I restarted and I got no audio after that. I got the "no sound" icon when trying to change volume.
# I did a search and found the following command to restart '''coreaudiod''': '''sudo kill ps -ax | grep 'coreaudiod' | grep 'sbin' |awk '{print $1}'''' to restart '''coreaudiod'''. It worked, but for a short period, after a day or two the audio stopped working again and I got the same “no sound” icon. I tried the command again, but now it didn't work, not only that, inside '''system preferences > sound > output/input''' there was no devices listed (internal speaker and mic should be there).
# Did NVRAM reset multiple times, didn't work
# Did SMC reset multiple times, didn't work
# Installed clean macOS Mojave, didn't work
# Updated to macOS Catalina, didn't work
# Tried plugging in P2 headphones, didn't work
# Only bluetooth headphones works
# Opened the MBP13 and disconnected and connected the left and right speaker, didn't work

I'm afraid this is a hardware failure, I don't know if it's a logic board issue or speakers issue. If it were only the speakers, the internal mic should still work, right? But, that's not the case as the mic doesn't work either. What do you guys think?