Skip to main content
Help

Current version by: Peter Iannone ,

Title:

USB Ports on Right Side Don't Recognize Storage or Network Adapter

Text:

Hi, I recently got a new MacBook Pro 16” and ended up returning it due to a problem with the USB ports on the right side of the machine (the ones nearest the touch id/power button).

The ports on the right side can be used to charge the laptop and will provide power out to charge an iPhone.

The ports on the right side also output video to my monitor.

However, when I connect an external USB drive to the ports on the right side, nothing happens. Opening up System Report shows that the drive is connected but it isn’t recognized as storage.

Also, when I connect a Belkin gigabit ethernet adapter to the right side ports it nothing happens for a while but after a couple of minutes it says that the machine has a self assigned ip address and cannot connect to the internet.

The usb ports on the left side can do everything that the ones on the right side can do plus when I plug in an external USB drive it is instantly recognized, and same for the USB ethernet adapter.

In the process of troubleshooting I reset the NVRAM, PRAM and SMC but none of those fixed the issue. I also reproduced the issue in Safe Mode.

Just curious if anyone else has experienced this issue.

Device:

MacBook Pro 16" 2019

Status:

open

Accepted Answer:

+610820

Original post by: Peter Iannone ,

Title:

USB Ports on Right Side Don't Recognize Storage or Network Adapter

Text:

Hi, I recently got a new MacBook Pro 16” and ended up returning it due to a problem with the USB ports on the right side of the machine (the ones nearest the touch id/power button).

The ports on the right side can be used to charge the laptop and will provide power out to charge an iPhone.

The ports on the right side also output video to my monitor.

However, when I connect an external USB drive to the ports on the right side, nothing happens. Opening up System Report shows that the drive is connected but it isn’t recognized as storage.

Also, when I connect a Belkin gigabit ethernet adapter to the right side ports it nothing happens for a while but after a couple of minutes it says that the machine has a self assigned ip address and cannot connect to the internet.

The usb ports on the left side can do everything that the ones on the right side can do plus when I plug in an external USB drive it is instantly recognized, and same for the USB ethernet adapter.

In the process of troubleshooting I reset the NVRAM, PRAM and SMC but none of those fixed the issue. I also reproduced the issue in Safe Mode.

Just curious if anyone else has experienced this issue.

Device:

MacBook Pro 16" 2019

Status:

open