Skip to main content

Fix Your Stuff

Right to Repair

Store

Help

Current version by: M Millecamps ,

Text:

I have a lenovo x220 and had the same problem. Altough I checked the temp and it wasn’t excessive I have just changed the thermal paste and it has been working for 5 hours without shutting down. Before I couldn’t use it for 20 minutes and afterwards it kept shutting down all the time, even when idlenidle even in the bios. I found a forum thread where this was the solution for many people with the same lenovo.
I have a lenovo x220 and had the same problem. Altough I checked the temp and it wasn’t excessive I have just changed the thermal paste and it has been working for 5 hours without shutting down. Before I couldn’t use it for 20 minutes and afterwards it kept shutting down all the time, even when idlenidle even in the bios. I found a forum thread where this was the solution for many people with the same lenovo.
 
Techs will tell you to change the motherboard. But it seems that this worked out for many people with this problem.

Status:

open

Original post by: M Millecamps ,

Text:

I have a lenovo x220 and had the same problem. Altough I checked the temp and it wasn’t excessive I have just changed the thermal paste and it has been working for 5 hours without shutting down. Before I couldn’t use it for 20 minutes and afterwards it kept shutting down all the time, even when idlen even in the bios. I found a forum thread where this was the solution for many people with the same lenovo.

Techs will tell you to change the motherboard. But it seems that this worked out for many people with this problem.

Status:

open